Logic 2.2.17

Download Links

What’s new

  • About dialog (including software version)
  • Python high-level analyzers: print statements now print to the terminal inside of the app.


  • Notify when an extension reloaded successfully

Bug fixes

  • Fixed saving marker note to .sal file
  • Intermittent shutdown crash
  • Fixed application hang-up on USB error on non-English Windows computers
  • Fixed missing data for analyzer V1 (everything except for SPI, I2C and Serial)

Python High-Level Analyzer print support

About dialog

This is the first update in quite a while where Logic2 hasn’t told me it was available and facilitated downloading and installing it. :slightly_frowning_face:

You were probably too fast for it, as the app checks for new version on launch and every 6 hours

Fair enough. I guess in the past updates have become available while I was sleeping and maybe the web notice came a little while after. I often seem to download the update through Logic2 before I see it here.

Nothing like doing production work on the bleeding edge. :smiley:

1 Like

The comments for the previous release 2.2.16 are still valid.

Another minor detail:changing the zoom doesn’t update the first line px = ms.


I know dark mode is fashionable, but most implementations actually allow to choose between normal (black on white) and dark (white on black) mode.

  • Do you plan to add normal mode to Logic?

@rei_vilo I somewhat agree. As a general thing I prefer paper mode (dark on light) than CRT mode (light on dark). For rendering signal traces however light on dark allows a much wider color and intensity pallet.

I would be in favor of a paper UI with a CRT signal pane, at least as an option.

1 Like

Yes, we have plans but no timeline yet

1 Like

Another question: I couldn’t manage to find the search tools.

Are they already implemented, or should we wait for a future alpha release?

Saving a 4.5 sec USB decoded tranfser takes around 55 seconds on a decent laptop with a i7-6600u.

Is there anything planned to speed this process up?

The data table search is almost ready. Probably in a week :slight_smile:

1 Like

We can look into this. Can you share with us a capture?


I just noticed that the analog channels could be the problem. The file is around 340MB.
I can send it to you anyway via Firefox Send.

Is there a way to for example disable the analog channels in a read-only session and then “resave” it?
This would greatly increase the load speed of the saved capture.

Oh, it makes then, there is quite a lot of data to save there :slight_smile:

Is there a way to for example disable the analog channels in a read-only session and then “resave” it?

Not at the moment, would you like to add that to our feature requests board?

I have added it to your feature request board.

Speaking of USB Transfers - There was a discussion earlier on, about being able to do some form of data reduction on the USB data. Back to about 2.2.6… In where I mentioned with the released Logic software I would save away one of the USB reports (CSV file), that might have a million or two lines of output, and how using linux grep and sublime text editor I can often reduce this down to a few hundred lines (or less) of actual messages (those which send or receive actual data)… (March 13th post)

At the time (back about mid March) I sent a SAL file by email, which it sounded like maybe a HAL could be produced for it. Although at that point only Serial, I2C, SPI had support for HALs. Last I checked it sounded like that was still the case?

Thanks again


P.S. - I still miss having the screen shot capabilities. I get by, by PRINT-Screen then bring up Photoshop…

1 Like

Hi Kurt,

Adding HLA support to our USB analyzer is still on my radar :slight_smile: . It’s about 75% there, but unfortunately other tasks have taken priority. You’ll be the first to know when it’s ready!


Total failure and rejected promises…until I installed libnsl.so.1

I’ve been using the various alpha releases for a while, but when I tried version 17 the app would not start. The previous version I was using, 14, worked great.

This is on CentOS 8.1. Looking at errors, it seemed that it might be related to libnsl.so.1 – and indeed installing that fixed the problem. I’m not sure what happened between 14 and 17, though.

Looking good, otherwise. I am really looking forward to using the saved presets.

1 Like

Thanks for posting it here for others!
It’s hard to support every Linux distro unfortunately (we currently test mainly on Ubuntu)

We’d love to get your feedback on presets

I was very confused about presets usage. I saved and then tried to find the file and could not. I had to dig around to find the export functionality so that I could share the presets with other people. Maybe a note on the save page would be useful.

1 Like