Logic 2.2.3 - Download here!

Logic 2.2.3 is now live!

Note: Version 2.2.2 was broken new users. We uploaded a fix on 2.2.2

Download Links

We would love to hear your feedback! Please reply here and share your experience - screen recordings are welcomed!

Alpha Mailing List

Join the Alpha Users Mailing List to be notified about the next release!

What’s new

  • :straight_ruler: Measurements - you can now select a region (Shift + drag) and get basic measurements for that range. This is a basic version and a lot of features are coming soon, such as Python support and data tooltips
  • :rocket: Better memory management and adjustable buffer size
  • :floppy_disk: Store and reload analyzers when re-opening the app
  • :rocket: Scroll up/down over the graphs using alt/option key + scroll
  • :running_man: Jump to next/previous digital transition
  • :rocket: Improved serial terminal - analyzer results now match to analyzer color
  • :hourglass: Process back-logged data when stopping a capture
  • :rocket: App stability improvements and bug fixes

Coming next

  • Python measurements
  • High-level Python analyzers
  • Improved live view
  • Decoded protocols table

Just tried the OSX version and it just comes up with a blank black window. Tried doing a refresh and shows saleae … then clears and goes black. No options, settings or widows in the main black window.

Sorry about that. Have you installed any of the previous versions or is it the first time you’re trying Logic 2?

I tried the Linux Logic-2.2.2-master.AppImage on an up-to-date x64 Ubuntu 18.04 and am getting a black screen. I remove ~/.config/Logic : no change. Also tried env LIBGL_ALWAYS_SOFTWARE=1, which fixes a black screen problem on Eagle, and it didn’t help either.

Have you had any issues with previous versions? It seems to be working on our Ubuntu 16.04 :frowning:

I get the same behavior as jamesarm97 described on Win10.

Which version did you have before (if any)? I suspect that it might be related to some upgrade function in our code.
Sorry about that :frowning_face:


FWIW, 2.2.1 works as expected.

It’s your first install of Logic 2 then, thanks for letting us know.
And if you update it from 2.2.1 to 2.2.2, does it happen again?

The issue was fixed, 2.2.3 should work perfectly :slight_smile:

The issue was fixed, 2.2.3 should work perfectly :slight_smile:

The issue was fixed, 2.2.3 should work perfectly :slight_smile:

Traces Disappear

After a capture is complete, I was scrolling and zooming in and all of the traces and analyzer bubbles all disappeared. Nothing I tried brought them back. The GUI did not crash because I could start a new capture OK. I could see the scroll bar on the bottom moving as I zoomed in and out with no traces. I’ve seen this happen a couple of times.

The screen shot shows a part of an orange bubble is still there in the lower left if that is a clue. I had two analyzers active and had the cursor on the trace for the bottom channel when I was zooming.

The timing display bar (above the channels) is also missing. I suspect that it’s a webgl issue. Which OS are you using?

EDIT: Do you see the timing display again if you start a new capture?

I’m running Windows 10

If I start a new capture everything comes back including the timing display, waveforms and analyzer bubbles.

It’s not webgl then…
I’d love to get some more details, I’ll reach out to you via email and ask for some more details.

Here is another one if that is helpful. This happened when I was doing the same sort of thing - scrolling.