Logic 2.2.4 Download Here!

Logic 2.2.4 is now live!

Note - this is a small release with some much needed bug fixes and small to medium improvements that we wanted to get out sooner than the rest of the features we’re working on. Python Analyzers & Measurements are still in development, but are getting close to release!

Download Links

We would love to hear your feedback! Please reply here and share your experience - screen recordings are welcomed!

Alpha Mailing List

Join the Alpha Users Mailing List to be notified about the next release!

What’s new

  • Added tooltip to range measurements
  • Updated marker deletion to delete all selected markers.
  • Added keyboard shortcuts to more context menus
  • enabled ctrl+A and ctrl+C shortcuts to copy contents from the protocol results terminal
  • Improved error reports so we can catch and fix more bugs!
  • Ctrl + and Ctrl - now increase/decrease font size & zoom the entire application.
  • Updated other keyboard shortcuts - press ‘?’ In the app to view.
  • Fixed display of device connection progress percentage
  • Fixed that really annoying NaN bug!
  • Optionally change the trace colors to match the channel colors.
  • Improved analyzer bubble colors

Coming next

  • Python measurements
  • High-level Python analyzers
  • Improved live view
  • Decoded protocols table

Screenshots

New trace color option

New measurement tooltip

Application zoom (ctrl -/=)

Hi,

I wanted to relaunch 2.2.3 after testing 2.2.4, but it does not work anymore: the “initialisation” grey screen gets replaced with an empty screen after a couple of seconds, and nothing more.

Ok, ~/Library/Application Support/Logic should be removed as a workaround.

BTW, should not it be ~/Library/Application Support/Logic2 to match the application name?

1 Like

I think there is a regression with 2.2.4 vs. 2.2.3:

A mouse right-click on the channel left column no longer allows to set the channel height as the current height: this context menu is no longer activated on right click (macOS version)

May be this menu
saleae-2.2.3
has been moved somewhere else?

Hi @Emmanuel, we noticed the 2.2.4 -> 2.2.3 problem too, which reminds me, I need to open an issue to detect downgrades and automatically reset settings. Something in the 2.2.4 settings changed in an incompatible way with 2.2.3.

Also good catch on the folder name. Internally, the exact name of the software isn’t perfectly consistent. Technically it’s Logic 2.2.4, and we call it “Logic 2” but the application name is “Logic” on Windows and Linux. On MacOS we renamed it “Logic2” to allow side-by-side installs with the older Logic 1.x software. It’s something we’ll probably adjust in the future.

Lastly, that right-click context menu was moved to the channel itself, we removed it from the channel label.

Ok, thanks for the update.

Analyzer Colors

Thank you for adding the ability to point at the decoded data from the analyzer and have it pop up the decoded text. This is very nice and saves lots of zooming in and out to read the data.

image

Second, my old eyes are having issues seeing the difference between between the colors on the analyzer labels. I’m particularly having issues telling the difference between blue and green if they are far apart on the screen. Red and purple are hard but not as bad as the green and blue. Is it possible to increase the size of the block of color next to the label? I think that would help.

image

@markp, good point. We’ll take a look.

In the meantime, try pressing ctrl -/= to zoom the entire display larger or smaller. It’s the same feature from web browsers, it will scale the entire application. Let me know what you think, and if you have any trouble with it!

  • Analog/Digital sync is variably mismatched. I have my digital signals and two analog signals (one analog/digital). When I am zoomed out, the digital signal shows as starting ms before the analog signal it is derived from. When I zoom in, that time mismatch shrinks until when I am looking at dozens of nanoseconds, the analog signal appears to be ahead of the digital signal. Time mismatch is bad. Variable time mismatch sucks. Or maybe it is a constant horizontal distance from some point?

    Update: I restarted the app. All configuration went away and after I set up everything again it was working without problem.

  • Was trying to set Trigger “On what channel”. I scrolled down the list of channels since it was too big for one menu, but even so the last channel (channel 8 on a LP16) was just barely on-screen–I could only see a few pixels of highlighted background. Fortunately I could knew it was probably there and could select it. This depends on font size.

  • Trigger may not be working reliably. As previously described I had trigger on channel 8, and it is a rising edge trigger. On the digital waveform I can see the transition, but the capture did not stop. Note if I have an analyzer it is able to decode that channel. It wasn’t working until I started to document the problem. Hmm.

    Update: As above I restarted the app. The trigger failure reappeared. I then did random testing of my target for a few hours, and tried the trigger again. This time it worked.

  • Cannot save system configuration (capture, names, order, sizes, etc) to allow restore later, important when testing different things

    Update: As above, sometimes it doesn’t even preserve the current configuration across an app restart. Note that there does not appear to be a clean way to quit the app, so I just delete the window.

  • Minimum digital channel height too large (with only two values you might not need a lot of space!)

  • Would be nice if there was a smaller vertical zoom granularity so that I can use all of the channel height for signal instead of having 10% free or the peaks clipped (e.g. shift-control). Better if there was an autozoom ability.

New Feature - Display Help Text / Version info

As a reporter I would like to find the version number at a place in the GUI :).

As a user I would like to have some reaction if I press F1, like open a help window or so. Just a view friendly lins stating:

" This is version XYZ, This software is a frontend gui to the salea logic analyzors find link here … , post bugs to XYZ, general help you’ll find …"

…I’m excited to see this python plugin =)

1 Like

New Feature - Counting analysed packages

I’m so excited, I’ve optimized my code an now my I2C is no longer walking, it’s running!!!
Ok, now I want to know how many packages I can transfare is a certain amount of time…

  • As a user a index detected packages would be nice. This index could be displayed in a column besides Value, Start, Duartion (I like the Hook you can set / unset to disable coulums)

  • Would it be useful to have the possibility of moving those columns in a analyzer around?

  • as a enthusiastic user I would like to have some properties of a Markers Pair, e.g. how many packages are included in it.

  • As a former user of elliSysUSB Logic analyzer I really preferred the possibility to set a time reference. All timestamps of a package before the referenced one have been negative and those afterwards positive.

Most of the ideas are focused on analyzing the performance of the code, aiming for statistics.

1 Like

Another round of changes - we switched to lighter colors (works much better in the terminal) and increased the label color a bit. What do you think?

I scrolled down the list of channels since it was too big for one menu, but even so the last channel (channel 8 on a LP16) was just barely on-screen

Can you please share a screenshot? It seems fine on my screen but maybe I misunderstood you :slight_smile:
There are two scrollbars, one for all of the settings and one for the dropdown, is that the issue?

Trigger may not be working reliably.

We’d love to reproduce it here locally, can you share with us some more details? What are your capture settings? Which OS are you running? Do you have any analyzers? Thanks!

Cannot save system configuration

We don’t have that feature yet. You can vote for it here if you’d like :slight_smile:
https://ideas.saleae.com/b/feature-requests/save-capture-settings-as-presets/
However, when you close the app, it should store the settings and load them on the next launch. Does it work for you?

Minimum digital channel height too large

We’ll look into this - most of the space is used for the measurements, we should eliminate this space if you turn them off.

Better if there was an autozoom ability.

There is, you can right-click on a channel and select fit vertically, or click on the fit button (top right corner of the channel row).

Thanks a lot for the feedback!

You can see the version info but it’s quite hidden…
It’s in the device selector dialog. We’ll add an about section in the app soon :slight_smile:

Related screenshots.

First three are showing the time mismatch. The last is showing the inability to fully see the last trigger name.

We’ll look into the mismatch, thanks for sharing the screenshots!

In regards to the trigger, there is another scrollbar to the right of the dropdown that will allow you to scroll all the way down. However, the user experience is not ideal and we should fix it :blush:

Nested scrollbars. I never suspected.

As far as the trigger problem goes, this is an old Fedora 25 (hopefully updated soon). When it happens again, I’ll capture what the setting are.

Thanks, these changes are really great, I’m a big fan. (and will be getting another 16 Pro!)

1 Like