Logic 2.2.1 - Download here!

Logic 2.2.1 is now live!

We would love to hear your feedback on every release! Please reply here and share your experience - screen recordings are welcomed!

Download Links

Alpha Mailing List
Join the Alpha Users Mailing List to be notified about the next release!

What’s new

  • Files versioning - All previous versions of .sal will not be supported. All future versions will be supported forever :crossed_fingers:
  • Digital and analog data now lined :straight_ruler:
  • Timing markers and pairs look are awesome now! :muscle:
  • Updated channel indicators and colors :rainbow:
  • Improved time format :timer_clock:
  • Improved error management :warning:
  • Trim view to existing data in looping mode :scissors:
  • Double-click to zoom in :mag_right:
  • Bunch of bug fixes

Coming next

  • Advanced measurements
  • High-level Python analyzers
  • Improved live view
  • Many more surprises :slight_smile:
1 Like

I tried release 2.2.1 on a real case involving I²C on my MacBook.

  • There is still a huge issue with readability.

I’ve been reporting this from the very beginning. Light grey on dark grey is really hard to read.
The tick for selected channels is too small. Please use the Export Raw Data presentation mentioned at Alpha 13

  • How to move within a trace?

Previous release has very handy shortcuts, N for Next and P for Previous, and arrows.

  • How to perform a multi-bytes search?

For example, I’m looking for the 0xBA 0x18 0x65 pattern.

  • Where are the export options for the analysers?

New only offers

while the data is already there

Previous release offered


I’m expecting a more advanced format with one line per packet

For all those reasons, I am still using 1.2.18.


two suggetions:

  1. in the decoded protocols Terminal view, mark different analyzers in different colors to identify which data came from which channel.

  2. a minor issue that should be fixed - the analog line is not displayed properly as a continuous line

  3. Currently, I can’t use channels 8-15 at all (I have a 16-channel salea pro connected) and I’ll be glad that this issue will be resolved quickly.

First of all, thanks for the feedback!

  1. That’s a good idea! I added it to our new feature requests board
    We still have some work to do on the terminal view, however, we first want to fix and improve the analyzers themselves :slight_smile:
  2. It’ll be fixed in a week or two.
  3. Can you provide us with some more details? How do you connect the device to your computer (USB 2/3, adapters, etc)? Which OS? Do they work with Logic 1?


regarding 3(im working on win 10), it was a matter of usb2 vs usb3 ports. when I was in usb2 it blocked the chaneels, on usb3 they are all opened. it’s consistent with Logic 1 so all’s good :slight_smile:

I’d posted a couple days ago about crashing I was seeing with all my app images while running Debian 10. I thought there was some issue with an update to the OS but I’ve narrowed down the problem to having an external monitor connected. I’m running Debian 10 on my thinkpad X1 and can run the Saleae software fine with no external screen connected, but when i use an external monitor the app exits with a segfault. Has anyone else seen anything like this?

Note the Logic 1.2.29 runs fine with an external monitor.

I’m having a very strange issue with the initial display when I start the app. There is corruption in the capture window. It occurs whether the Pro device is connected or not. If I hit the “Capture Settings” a couple times (so fold out window appears/disappears) it disappears, also if I resize the window (depending on the size) it disappears or reappears. This issue didn’t occur in the last version I was running (2.1.5), but now occurs in both versions. Versions 1.x all work fine - no issues.

Running Mac OSX 10.12 on a Z600 Hackintosh (if relevant).

It’s more of an annoyance then anything… still works fine once I get the window cleaned up. I was more curious to see if any others have had similar issues.

I’m happy to hear that. We should notify users and let them know that their usb port doesn’t support more than 8 channels.
I added that to our tasks list :slight_smile:

Hey Rei,

As always, thanks for the feedback! :slight_smile:

  1. Readability issue - I’ll discuss that with our designer again. My apologies
  2. When your mouse is over one of the channels you can use the keyboard to move left or right. In addition, we’ll add the ability to jump to previous/next transition on the next release.
  3. You can’t perform multi-byte search at the moment. We’re working on High-level analyzers, and as part of that, you’ll be able to group multiple bytes into one result and then search for it. Would that work for you?
  4. We’ll add the option to export analyzer results soon (we’re already working on it). It’d be similar to the Logic 1. We’re also planning on improving the results table significantly to support more data columns. Once we do that, you’ll be able to filter results and export the table.

Thanks for trying the new version, I know that some features are still missing but we’re working on it! :slight_smile:

First of all, I’m glad that it’s working on the built-in monitor at least :slight_smile:
We haven’t seen this bug anywhere except for your machine. I’m really sorry but I don’t think that we’d be able to fix the issue at the moment

I’m sorry, but we’ve never seen this before :flushed:

It might be related to WebGL or maybe to Mac OSX version, as we mainly test the app on OSX 10.14 and 10.15. If it happens also with 2.1.5 now, it sounds like it more related to your machine, but again, I’m guessing here.

Long Capture Being Truncated

I setup a capture to run 23 seconds after the trigger, and it stopped after 10 with no messages. I can see the about of memory being used increasing to 2G and then it stops. I have 16G of RAM in my machine, so 2G is nowhere close to what it could use. The Digital channels are set to sample at 125 MS/s and the Analog channel is set to sample at 50 MS/s.

Notice that this time it gave me 9 sec pre-trigger, and less than 1 sec post trigger

Is there some reason that it cannot use more than 2G? I tried setting the option to trim to the last 5 seconds post-trigger, but that made no difference.

Thanks for the quick response. I’ll try to dig in more and let you know if what i find. For now I’ll continue using without an external display.

1 Like

It looks like your particular crash is happens when we are scanning USB devices. Are you connecting your external monitor over USB? If so, I’d be curious if using a different connection (hdmi, displayport, etc.) would resolve your issue.

We just fixed the memory management system to notify you when we have to stop the capture. It’ll be available on the next version (in a week). We’ll also add an option to select the max memory usage.

My apologies for the bad experience :blush:

Same problem for me, same symptoms since 1.2.29.
I’m running Ubuntu 19.04.

Window open with “initializing” prompt then crash when I plug/unplug my saleae (line “Failed to get crash dump id.”)

2020-01-28 09:53:17.770600:[0x00007ff83ea0f480]: boost::log::keywords::file_name: /home/ftrefou/.config/Logic/logs/graphio-2020-01-28--09-53-17.log [ /home/travis/build/saleae/graph-io/core/saleae_base/src/saleae_log.cpp:152: void Saleae::SetLogFileName(const char*) ]
2020-01-28 09:53:17.770756:[0x00007ff83ea0f480]: boost::log::keywords::target_file_name: /home/ftrefou/.config/Logic/logs/graphio-2020-01-28--09-53-17--%5N.log [ /home/travis/build/saleae/graph-io/core/saleae_base/src/saleae_log.cpp:153: void Saleae::SetLogFileName(const char*) ]
2020-01-28 09:53:17.770766:[0x00007ff83ea0f480]: boost::log::keywords::target: /home/ftrefou/.config/Logic/logs [ /home/travis/build/saleae/graph-io/core/saleae_base/src/saleae_log.cpp:154: void Saleae::SetLogFileName(const char*) ]
Server: Opened connection 0x3e9462b70200
2020-01-28 09:53:18.996235:[0x00007ff829ef4700]: GraphInitRequestData SeesionId: -2 [ /home/travis/build/saleae/graph-io/server/graph_server/src/graph_server_internals.cpp:342: void Saleae::Detail::GraphServerInternals::RemoteRequestHandler(const Document&) ]
2020-01-28 09:53:19.005943:[0x00007ff829ef4700]: GraphInitRequestData SeesionId: -1 [ /home/travis/build/saleae/graph-io/server/graph_server/src/graph_server_internals.cpp:342: void Saleae::Detail::GraphServerInternals::RemoteRequestHandler(const Document&) ]
State Handler [1]
State Handler [1]
State Handler [6]
State Handler [11]
2020-01-28 09:53:19.129331:[0x00007ff829ef4700]: DeleteGraphData SeesionId: -2 [ /home/travis/build/saleae/graph-io/server/graph_server/src/graph_server_internals.cpp:355: void Saleae::Detail::GraphServerInternals::RemoteRequestHandler(const Document&) ]
Failed to get crash dump id.
Report Id: {"response":"ok","_rxid":"f6000000-a
Segmentation fault (core dumped)

EDIT: I’ve managed to get it working with external monitor. On my XPS15, there is a built in HDMI and a thunderbolt USB-C. Crash happen when i plug my USB-Hub (official with HDMI port).
the hub: https://www.dell.com/fr-fr/shop/accessories/apd/470-abry

1 Like

Great! Is the app working properly now?
Looks like @huffman was right :slight_smile: