Logic 2.4.1

Download Links

Windows - Linux - MacOS

Thanks for all the feedback on the automation API! This release contains 2 bug fixes that came directly from user reports. It also includes support for a new hardware revision of Logic Pro 8 - nothing major, we just needed to change another component due to supply chain issues.

Quick reminder, starting with 2.4.0+, we’ve launched our new automation API for Logic 2! Learn more here. We would love to get your feedback on the automation API on this thread.


  • Support for Logic Pro 8 hardware Revision 6.0.0. No functional changes, this is just yet another revision change on the supply chain rollercoaster.

Bug Fixes

  • Automation API: Starting a capture immediately after opening the application would sometimes fail if all physical devices had not yet been detected. It now always waits for the initial scan to complete.
  • Automation API: Digital trigger linked channels were not being used in the trigger. This has been fixed.

In this release I get “Error connecting to socket” on NixOS. This did not occur on 2.4.0, it is new for 2.4.1. Is there a way to get more debug logs about this error?

2.4.1 was build using Ubuntu 20, while previous releases were built on Ubuntu 18. We didn’t catch any issues from this because we do all our testing on Ubuntu 20+.

I’ll bet that our C++ backend has an unmet dependency, and is failing to load. Internally we’re testing a rollback to Ubuntu 18 for the build.

More testing would be great. Could you run the following and send us the output? The following steps will extract the appimage, then run ldd on our backend library to see if that’s the problem.

./Logic-2.4.1-master.AppImage --appimage-extract
ldd squashfs-root/resources/linux/libgraph_server_shared.so
ldd -v squashfs-root/resources/linux/libgraph_server_shared.so

I’m guessing this is a glibc version issue, and if it is, us rolling back to ubuntu 18 would fix this.

However, we’re going to roll right back to ubuntu 20 next year when LTS ends, mainly because our CI provider is going to drop it exactly then, making it much more difficult for us to build on that version.

Also what version of NixOS are you using?

Thanks for the debug tips @markgarrison, that helped locate the problem!

TL;DR: I added libxcrypt to satisfy a missing libcrypt.so.1 and everything works now.

For completeness, here’s the answers to your questions:

I extracted the AppImage, and checked the linked libraries, everything was found except for libcrypt.so.1:

$ ldd squashfs-root/resources/linux/libgraph_server_shared.so
ldd: warning: you do not have execution permission for `squashfs-root/resources/linux/libgraph_server_shared.so'
        linux-vdso.so.1 (0x00007ffc9fecd000)
        libstdc++.so.6 => not found
        libAnalyzer.so => /home/alex/Downloads/squashfs-root/resources/linux/libAnalyzer.so (0x00007f18910a1000)
        libcrypt.so.1 => not found
        librt.so.1 => /nix/store/g8d5bnh9mh1364x17mjyc731fsi9a61m-glibc-2.35-163/lib/librt.so.1 (0x00007f189109c000)
        libnsl.so.1 => /nix/store/g8d5bnh9mh1364x17mjyc731fsi9a61m-glibc-2.35-163/lib/libnsl.so.1 (0x00007f1891083000)
        libutil.so.1 => /nix/store/g8d5bnh9mh1364x17mjyc731fsi9a61m-glibc-2.35-163/lib/libutil.so.1 (0x00007f189107c000)
        libdl.so.2 => /nix/store/g8d5bnh9mh1364x17mjyc731fsi9a61m-glibc-2.35-163/lib/libdl.so.2 (0x00007f1891077000)
        libpthread.so.0 => /nix/store/g8d5bnh9mh1364x17mjyc731fsi9a61m-glibc-2.35-163/lib/libpthread.so.0 (0x00007f1891072000)
        libm.so.6 => /nix/store/g8d5bnh9mh1364x17mjyc731fsi9a61m-glibc-2.35-163/lib/libm.so.6 (0x00007f1890f92000)
        libgcc_s.so.1 => /nix/store/g8d5bnh9mh1364x17mjyc731fsi9a61m-glibc-2.35-163/lib/libgcc_s.so.1 (0x00007f1890f78000)
        libc.so.6 => /nix/store/g8d5bnh9mh1364x17mjyc731fsi9a61m-glibc-2.35-163/lib/libc.so.6 (0x00007f188dc00000)
        /nix/store/g8d5bnh9mh1364x17mjyc731fsi9a61m-glibc-2.35-163/lib64/ld-linux-x86-64.so.2 (0x00007f1891153000)
        libstdc++.so.6 => not found

Adding libxcrypt fixed this.

Also what version of NixOS are you using?

NixOS unstable.

I also found running the executable with the --enable-logging to be helpful for debug, it also pointed towards graph_server_shared problems.

"PromiseWorkerError: failed to load graph_server_shared undefined", source: file:///nix/store/0dzh9scd0m0gx8mzv3mlh2xvxlwwzp3l-saleae-logic-2-extracted/resources/app.asar/dist/logic/bundle.js (118)
"error connecting to socket: PromiseWorkerError: failed to load graph_server_shared", source: file:///nix/store/0dzh9scd0m0gx8mzv3mlh2xvxlwwzp3l-saleae-logic-2-extracted/resources/app.asar/dist/logic/bundle.js (118)
1 Like

Not sure if this is the proper thread since I got my first Saleae 5.0.0 a few days ago and am running Logic 2.4.1 on Windows 10 22H2 and have a failure with Save Capture… / Open Capture…

  • I use File / Open Capture and I get “[RED X] Failed to unzip file” in lower left.
  • Logic 2.4.2 gives the same results, even with fresh capture and open of that capture.
  • I tried closing Logic and double clicking the file, it gives the same failure popup results.
    (Note, I have not tested earlier versions of the software)
    [ Edit: Yes, I was able to rename .sal to .zip and unzip the binary files out just fine ]
    [ Edit: FOUND IT – cannot use a Windows RamDrive ( ImDisk ) ]

FOUND IT – cannot use a Windows RamDrive ( ImDisk )

1 Like

After upgrading to 2.4.1. , Logic2 stopped to recognized my connected Logic Pro. It was recognized before the update and it is still recognized by the OS (MacOs 12.6.1)(as “Logic Pro”).

Is this a known issue? Would 2.4.2 fix it?

@Torsten Oh no! Sorry to hear that… Which Logic Pro model do you own? (Logic Pro 8 or Logic Pro 16), and can you share a screenshot like in the support article below of how it appears in the USB tree in Apple’s System Report? Please unclude the

We didn’t introduce any major updates in 2.4.1 besides adding support for revision 6.0.0 hardware. Did 2.4.0 work previously with your device? If so, can you confirm if reverting back to that version (or whichever older version you last remember working properly with your device) solves the issue for you?

I would also be curious to know the results of the above tests on another PC to double check if your hardware is still OK.

Hi @timreyes,
I’m using the Logic Pro 16. Find attached the screenshot of the current situation. I’m 100% sure, that it wrote “Logic Pro” when the error happened in the report (instead of “WestBridge”).

I’m not 100% whether I’ve upgraded from 2.4.0 or an earlier version. Funny enough, when I just wanted to lookup the currently installed version, I found it to be 2.4.1. and it is working.

Hardware is for sure ok, because I used it after I’ve rolled back the version to 2.4.0. And now with 2.4.1 it still seems to work.

@Torsten I’m glad to hear it’s working again. I’m not quite sure what could have caused that issue to begin with, however, do feel free to post again if you notice any further odd behavior or issues!