Issue with Logic startup

I am using salea for quite some time on my arch and manjaro distros. (My pro16 is at least 5 years old). It was nicely tacked away for the past year or so, and today when I tried to use it I got an error:

A JavaScript error occurred in the main process
Uncaught Exception:
Error: /tmp/.org.chromium.Chromium.tGv5XQ: failed to map segment from shared object
    at process.func [as dlopen] (node:electron/js2c/asar_bundle:5:1800)
    at Object.Module._extensions..node (node:internal/modules/cjs/loader:1170:18)
    at Object.func [as .node] (node:electron/js2c/asar_bundle:5:2027)
    at Module.load (node:internal/modules/cjs/loader:982:32)
    at Module._load (node:internal/modules/cjs/loader:823:12)
    at Function.c._load (node:electron/js2c/asar_bundle:5:13331)
    at Module.require (node:internal/modules/cjs/loader:1006:19)
    at require (node:internal/modules/cjs/helpers:93:18)
    at bindings (/opt/saleae-logic2/resources/app.asar/node_modules/bindings/bindings.js:112:48)
    at Object.<anonymous> (/opt/saleae-logic2/resources/app.asar/node_modules/ref-napi/lib/ref.js:7:47)

I tried a couple of versions I had installed

  • I get similar behavior from 2.2.18,
  • 2.3.13
  • 2.3.54

I also installed from AUR the version 2.3.53 and running it natively but still I get a similar message. After this happens, there is no proper cleanup and I have multiple processes left dangling.

I searched a bit at google and it used to be an openSSL problem. Are there any other ideas?

My saleae seems to be connected on the system

Bus 001 Device 014: ID 21a9:1006 Saleae, Inc. Logic Pro 16

@Niko I’m suspecting this might be a software issue rather than a hardware one.

  • Can you confirm if the error comes up even with the Logic Pro 16 disconnected?
  • When exactly does this error appear? Upon software startup? What happens afterwards?
  • In case the hardware itself has nothing to do with the error (i.e. if the error still appears while your Logic Pro 16 is disconnected), I’d like to test the following:
  1. Launch the app with --no-sandbox and let me know if that helps.

./Logic --no-sandbox

  1. Take a look at the output of the following commands.

./Logic-2.x.xx-master.AppImage --appimage-extract (replace “x.xx” with the specific version of Logic 2)
cd squashfs-root/resources/linux
ldd libgraph_server_shared.so
ldd -v libgraph_server_shared.so

Afterwards, can you share the output with me?

  1. Can you test our older Logic 1.2.40 below? The error seems to be Electron/JS specific (which is what we use to build the Logic 2 app).
    https://support.saleae.com/logic-software/legacy-software/older-software-releases

  2. What versions of Arch Linux and Manjaro are you running?