Logic 2.3.10 operation

Not sure if this is intentional or not, but I have to close the GUI and reopen for it to see my Logic8 pro if I put the PC to sleep and leave the GUI open on the taskbar. Didn’t used to do this. Also, if I record a lot and am zoomed way out while recording to see a minute or so on the screen, when I stop the data automatically zooms to a “normal” zoom level and I cannot zoom back out. I can zoom in, but not out. Intentional? it wasn’t this way in 1.1.18. love the colors, and this is still the best logic analyzer on the market BY FAR for the price. Can’t beat it.

db

@david.bassett Glad to hear you’re still enjoying using the device!

I wasn’t able to reproduce this on MacOS or Windows 10. The device seems to stay connected to Logic 2.3.10 even upon waking the PC from sleep.

  • What operating system are you on?
  • If on Windows, can you try disabling “USB Selective Suspend” in the Power Settings?
  • If on Windows, you may also try not allowing the computer to turn off the Logic Analyzer to save power on sleep (Device Manager -> Right click Saleae Logic Analyzer -> Properties -> Power Management).

Hi Tim,

thanks for the options. I will try and repost if it works. I have a Windows 10 box from MSI called a Prestige 15 A10SC - also a great computer.

I use my Logic pro 8 every day and carry it around in my pocket to and from work. Will probably get a backup, but want to see what you have in store for scope next year before I get another Logic pro. Hope things are going good for you guys. it would kill me if you had to close.

db

Sounds good! Yes, keep me updated. Hopefully that helps.

As for the “zoom” issue you were experiencing, can you describe that in more detail? My understanding is that this may be normal behavior of the software. My guess is that something in your capture settings is causing that to happen.

Let me know any details. For example:

  • Your capture settings
  • The zoom level before starting the capture
  • How long you capture for before stopping it
  • Anything else you can share that might help, perhaps images

Hi Tim,

I have a couple of things here. First, I cannot see my old captures. If I double click on files i saved with 1.2.18 or 1.2.29, I get a no longer supported popup and the old GUI closes. This really hurts to the point I will have to remove 2.3.10 or sneakernet to another computer.

For the zoom, I have maybe 70S catptured, 6 channels recorded, 6.25MS/S, all digital, 2G memory buffer, 202K used (I2C and GPIO wiggles). I can’t get to see left of 2S, therefore any boot or powerup states. The other thing I remembered was during the capture the zoom level automatically adjusted the granularity during capture.

I attached the screen image.

db

timreyes
October 22

Sounds good! Yes, keep me updated. Hopefully that helps.

As for the “zoom” issue you were experiencing, can you describe that in more detail? My understanding is that this may be normal behavior of the software. My guess is that something in your capture settings is causing that to happen.

Let me know any details. For example:

  • Your capture settings
  • The zoom level before starting the capture
  • How long you capture for before stopping it
  • Anything else you can share that might help, perhaps images

Hi David,
For Logic 1 you can add an --override flag as described here: https://support.saleae.com/troubleshooting/unsupported-version

Also if you are interested in opening your Logic 1 capture in Logic 2 could you add your vote here? https://ideas.saleae.com/b/feature-requests/import-logicdata-capture

Thanks for posting that screenshot. It looks like you have trim after capture set to 30 seconds enabled and about 30 seconds of capture data is appearing, so that looks correct to me. If you want to see all 70 sec you need to disable Trim data after stopping shown below.

Hi Neel,

You guys are ABSOLUTELY, POSITIVELY, the best company for quality, ease of use, and service I have ever encountered in all the years I have been in high tech, and that goes back to 1976. You are unbelievable. Everything worked, and I will be on the web site getting the USB isolator in about an hour. Thanks as always.

Dave Bassett

1 Like

Thanks Dave! We really appreciate it!