Difficulty trying to do a long capture

I am trying to catch a hard problem to reproduce and am leaving our product with a Logic 8 Pro connected and logging overnight. Here are the settings:

I lock my computer, but do not shutdown or log out. Over the last 3 nights, 1st night it worked and was still logging when I came in. 2nd and 3rd nights the capture stopped and I have several (4-5) new blank session tabs at the bottom of the window, like the logic disconnected and reconnected several times. Last night it logged 1 hour and 2 min. before it quit. Two nights ago it logged for 1 hour and 46 min. before it quit.

I am plugged into a USB port directly to the laptop doing the recording. The laptop will not sleep or hibernate. The cable I am using is one ordered from saleae, the USB type-C plug to USB 3.1, 4ft. cable. Obviously my sample rates are as low as they can be set. The laptop “should” have no trouble keeping up, it is an HP Omen 12th Gen i9 processor with 16GB of RAM.

Is there possibly some power settings somewhere? I looked in the “Saleae Logic Pro 8 USB Logic Analyzer” properties under Device Manager, but there were not power saving options that showed there.

Thanks in advance for any tips or help.

@awolfe Sorry to hear about that! Based on the information you’ve provided, it sounds like you’ve done your due diligence to keep external error sources to a minimum, and I’m not able to immediately determine the source of the issue right now.

Since you mentioned power saving settings, you may also want to try disabling the computer’s ability to “turn off this device” to save power for your USB root hubs / USB host controllers under Device Manager > USB controllers section.

In short, Logic should continue to capture while the PC is locked.

Can you share the following information with me?

In case you prefer to keep your information above private, we would be happy to move this over to email if you send a message using the link below. You can provide a link to this forum post so that we know it’s you when it comes in.