Can't capture faster than 50MHz

Just downloaded Logic 2.4.7 for Linux and trying to take some captures with my Logic Pro 8. But when i try to take any capture with speed greater than 25MHz(25MHz - works OK, 50MHz and faster - doesn’t work) the program gives ‘ReadQueueError’ and does nothing.
Tested it both with connected wires and not. Tested starting it with sudo and without. Tested capturing from 1 to 8 lines. Nothing helps. The device is connected to USB 3.0 superspeed port. Tried different USB ports - doesn’t help. Tried other Logic Pro 8 that i have - doesn’t work, same error.
My OS is Kubuntu 23.04.

@joyibeb237 I’m sorry to hear about this! This error occurs while we’re attempting to queue the USB read requests at the start of the capture.

Although we haven’t seen this issue recently, in the past, we have seen unusual issues in this section of the code specific to Linux - specifically related to the number of reads we’re attempting to queue, which is related to the sample rate and number of channels enabled. Unfortunately our Linux debugging experience needs work. At the moment I don’t recall if we have a reliable way to collect back-end logs from that platform.

The software does periodically flush its logs to disk while running. The location of those files is documented here:

What I’d like to do is try and get the logs containing this error. Can you send any crash logs from that file location over?

Also, can you share your machine ID with us?

Finally, I’d like to check to see if this problem is related to the capture settings. Please test the following settings combinations with Logic Pro 8:
6 digital channels, 500 MSPS
3 digital channels, 500 MSPS
1 digital channel, 500 MSPS
1 digital channel, 100 MSPS
1 digital channel, 10 MSPS

Please run a few captures of each, and let me know if you see the error, and if you do see the error, how consistently the captures fail.