Saleae

Cannot load saved data Logic 2.0.7

I am running Manjaro Linux (fully upto date) and have been running Logic 2.0 Alpha for a while - I currently have version 2.0.7 Build 1191.

I have captured a few tabs of data and I saved them off from version 2.0.7. When I go to load them they are not shown in the load screen (also v2.0.7).
I noticed that the Logic software did not put an extension on them. I tried adding .logicdata, .logic, .capture, .capturedata all to no avail.

What should the extension be? Are my files corrupt?
(Note: I still have the program open with my original data and will not close till I get this worked out).

Thank you,
Chris

Hi Chris, thank you for this feedback - I’m sorry for this trouble!

Any chance you could upload one of these files to me? https://www.dropbox.com/request/edl8Ix2yfDiXH7bD1oyd

The new extension is .sal, but this shouldn’t actually matter - the alpha currently tries to load whatever you throw at it.

Are these especially large captures?

I’ll follow up when I have a chance to talk with some others about this.

Joe

Have you tried dragging the file into the application?

I see now that the menu-based “open capture” on Mac OS doesn’t let you select non-.sal files. Will get that fixed, and will try on Linux momentarily.

Ok Chris,

  1. The Linux version doesn’t put “.sal” on the end of the saved files (will fix)
  2. The Linux version doesn’t let you see/open non-.sal files from the Open dialog. (will fix)

You should be able to drag the files in, however, regardless of extension.

Thank you very much for reporting!!

Joe

I put .sal and all the files worked.
Drag and drop worked as well.
thank you.
-Chris

1 Like