Analyzing SPI gives Errors (also csv). What am I doing wrong?

Hello there!

The last month I’ve been trying to dump some flash memory but after the first few moments it starts spitting out errors “The initial (idle) state of the CLk line does not match the settings.” But the first .7 seconds of input are fine and errorless.

When I dump it to a csv and try to convert it into a bin with the Windows script (How to Export Serial Protocol Results to a Raw Binary File - Saleae Support) it will error: expected HEX formatting. I think I am doing something wrong at receiving signals maybe?

I am sorry if this is not clear. If I can give any more information you need, please let me know and I will try to comply! I am a total noob when it comes to reverse engineering/hardware hacking, but I am trying to learn.

Thank you very much in advance!


Sorry for the trouble with that.

As a first step, I’d like to try and figure out what could be causing the “Settings mismatch” errors you are seeing in your decoded SPI data. At first glance, it looks like the issue might be because the Enable signal is set to CH0 (under the SPI analyzer settings), which looks incorrect. It actually looks like CH0 is another clock line. Can you confirm the purpose for each of your channels?

I would also be happy to take a look at your capture file if you can provide that for me:

Looking forward to hearing back!

Thank you for your reply!

Currently I have connected the cables according to the pin configuration from their website (as far as I can tell) and assigned the channelroles in conjuction with this information. (MX25L6406E, 8-PIN SOP)

Here is (one of my) captures. Thank you so much for your help!

@tom.tijn.jansen Thanks for providing that! One thing we notice right away is that the sampling rate might not be fast enough. Judging by your clock signal, it looks like the speed is somewhere along the lines of 10+ MHz. Can you confirm this for me? Your capture sampling rate is currently set to 25 MS/s.

We generally recommend a sampling speed of at least 4x the speed of your signal.

Can you try increasing your sampling rate? You might need to disable unneeded channels to allow for this. Once you’ve tried that, and if that still fails, feel free to send me an updated .sal capture file.

@timreyes Sorry for my late reply. I really appreciate you helping me!

I will try it and let you know!