Analyser software stops with "Error Connecting to Socket"

Since one of the last update of my Linux distribution the Logic Analyser software (Appimage format) doesn’t start anymore. The analyser software stops at the startup screen with the message “Error Connecting to Socket”. I searched on the Saleae site to find a solution for the problem, but without any success. The only hint I found was, that it could be a problem with the OpenSSL library. Then I checked if on one of the latest OS updates the OpenSSL library was updated. This was the case. The OpenSSL library was updated from 1.0.2 to 3.1.2 . Could this the reason of the problem ?

OS: Linux Solus
Analyser Software: Logic-2.4.10-linux-x64.AppImage (I also tried older ones)

Have you opened up whatever “port/socket” number for SSL communications on your Linux OS?

@WIni-Buh Sorry for the trouble with that. We share some potential solutions in the support article below:

Unfortunately, Linux Solus is not one of our officially supported operating systems. For Linux version of the software, we develop and test our software primarily for Ubuntu as mentioned below.

Hopefully one of the workarounds mentioned in the first support article above helps out!

1 Like

Problem solved to run it under Linux Solus again.

It requires to install the libxcrypt-compat package. After that the Logic Analyser HW is recognized again and fully functional.

@timreyes Thank you very much for your help


I encountered exactly the same problem on Fedora 39(Logic-2.4.13-linux-x64.AppImage) . When I tried to start the program, I received a message about a socket connection error.
And the

sudo dnf install libxcrypt-compat

command solved this problem!

Just a command (which is discussed on the support page)

sudo dnf install compat-openssl10

didn’t help.
(for Fedora 39 it displays an error message:
Failed to resolve the transaction:
No match for argument: compat-openssl10)


Sorry for the confusion with regards to the dnf install compat-openssl10 command. That command was meant for our legacy Logic 1.x software crashing on Fedora 26 and 27, and is quite old information at this point. I have removed that section from the support article below to avoid any confusion in the future. I also added your solution to the support article. Thanks for sharing that with us!

1 Like