Error connecting to socket on Fedora 34


I am running Fedora 34 and I decided to try and check if Logic would work on my machine before resorting to other options. I have Logic 2.3.41.

When I open the application I only see this:

Screenshot from 2021-12-20 13-35-34

Has anyone been successful at making it work somehow?

We’ve seen this error reported a few times in the past. Here are some workarounds below:

I hope this helps!

1 Like

Thank you! It did help, I ran sudo dnf install libnsl and that did the trick :slight_smile:

However, now I have issues with the detecting my device. I have a Logic 8 connected and it doesn’t seem to find it. As far as I understood, there is no need to install drivers with Logic 2, is that right? I saw something about drivers on Linux but it looked to me like those instructions were for the legacy Logic app.

lsusb does list the device:

Bus 001 Device 009: ID 21a9:1004 Saleae, Inc. Logic8

@andresovela It’s possible a udev rule might be missing. I would have expected you to receive a popup in the Logic 2 app though. Can you try the solution below?

Yeah I did get the pop-up and ran the command in the terminal. Now I don’t get the pop-up anymore, but the device still does not connect.

Sorry for the frustration with this. If you saw the udev rules popup in the app before, that means our SW was able to detect the device.

My guess is that now it’s able to connect to the device but some error occurs during the connection, and the SW silently fails. We’ve added device connection error reporting, but it won’t be in the app until the next release.

In the meantime, the terminal where you launched the SW might have output that could include a connection error. I suggest logging the output to a file like so:
./Logic-2.3.41-master.AppImage > logiclog.txt
Then connect the device, wait 10 seconds, disconnect it, then close the software and send us the log file.
There is a chance that won’t include what we need, in which case I’ll need to send you the back-end log file location so you can check for logs there.

Lastly, please give our old 1.x software a quick try, at a minimum, it will display an error if an error occurs when trying to connect to the device.

I’ll come back to this first thing in January, since I’m officially on holidays now :smiley:

I appreciate the support during this time! I wish you happy holidays :slight_smile: I’ll reach out again next year :wink:

Now it works for some reason. I installed the OS software updates that came over the holidays, maybe something got fixed there. Thank you for your support!

1 Like