Alpha 11

Marc, no, I didn’t do any saving of captures. I was running the I2C analyzer though.

I’ll do more testing to see if I can reproduce it on my system.

Hi Brian,

how long do you usually record for? If you had to guess, how many I2C bytes do you think you record in the typical recording?

We have some pretty serious performance problems with protocol analyzers in the Alpha, this release is a lot slower than the production software. I’m working on it right now.

In testing, it looks like the Analyzer performance problem affects other parts of the application too, like rendering.

I’d like to try replicating some of your capture details - capture length and number of bytes - to see if I can uncover what’s happening.

My near term goal is to get I2C to decode in real time - e.g. 400 KHz I2C with near 100% bus utilization.

Mark, thanks so much for working with me on this issue. In the case where I had the above mentioned problem, I had probably captured several thousand bytes of I2C (not a whole lot). The total capture was probably 30 seconds long.

I have been working for awhile this morning to reproduce the problem as described above, and of course I can’t. :grimacing: However, I had a different type of crash which left my system in the same state. Same setup as above, but after I clicked “Start”, the button changed to “Stop”, said something about calibration, and then nothing happened. No data was captured, and clicking “stop” didn’t do anything. I had to close the app (with the normal X ), but then I’m left with the same four Logic processes (no Java.exe) with one consuming 30% of my CPU, and unable to connect to my Logic hardware with either version of the Logic app.

I’m not sure how much that helps you, I guess it’s good that we have to work hard to make it crash? (Rather than crashing all the time on its own)

OK, it feels easier to get bad things to happen now that I’m getting good at it. I got the crash to happen on the first try!

So I just killed the four Logic processes from Task Manager, fired up 2.0.8, no analog, all 16 digitals, I2C analyzer on channel 0 (SCL) and channel 1 (SDA), 20 MS/s, 3.3V, click Start. I captured probably 15 seconds of data (which looked like it worked fine) then I clicked Stop, and the ‘back end’ seemed to hang up. UI is fully responsive but no matter what I do with zooming in and out, all I get is this tiny chunk of data, which doesn’t change size even as I zoom in and out with the mouse wheel.

Closing the Logic window then gives me the four zombie processes and no access to my Logic hardware until I kill them.

Thanks Brian,

My guess is that 1 thread in the backend is stuck in an infinite loop, but it’s hard to tell.

Since the software isn’t hard crashing itself, I would guess that no error reports are being uploaded.

Back-end log files are stored here:

Could you open that folder after the application hangs up and you kill it off, then sort by Date modified and send the latest files? There should be one or two files with the same time stamp in the file name, such as:


Hopefully that will shed some light on the last thing the application was doing.

Besides that, it’s likely we will be able to reproduce this simply by replicating your test setup. We already use a very similar setup for testing.

With regards to the calibration crash, that sounds like it’s a race condition. Was your computer connected to the internet at the time you saw that issue?

And, of course, now that I’m trying to recreate the crash, it JUST WON’T HAPPEN. I will continue to try and let you know when I do create it again, and send you the files.

The calibration crash - yes, my computer was connected to the internet when that happened. I think.

Thanks Brian, we definitely have our work cut out for us. The next release will have a few serious back-end issues fixed, but the analyzer processing performance and associated issues still need a lot more work before they are resolved.

Brian, we just found and fixed a bug in the Alpha related to the I2C analyzer. turns out that if you set the SDA and SCL channels backwards, save the analyzer, and then try to correct them, the I2C analyzer would get caught in an infinite loop while trying to shutdown and completely freeze the backend. I think this is the same issue you’re seeing.
It was an easy fix, will be in the next release.

Suggestion: dark interface option, iTunes style (sorry, ‘Music’ on Catalina)


Suggestion: ASCII display for Serial Analyzer


I’m probably missing something. What’s the difference between that and our current theme?

You can change the display radix to ASCII via the analyzer menu on the sidebar (by hovering Async serial). It will be easier in the next release

1 Like

Found it! Works great :slight_smile: thanks

The theme change is just the integrated/dark title bar.
(Also: The current title bar is light even if the system is set to dark)

How do I change the vertical scale? The interface seems to be auto-scaling, because before sampling it was ±10V, but after sampling it jumped to ±40V, which seems strange for a 3.3 V signal.

Ohhh, I indeed missed it. We’ll fix that in one of the next releases (as part of supporting themes).

You can zoom in vertically using ctrl + mouse scroll or ctrl + touchpad swipe up. We’re working on improving these interactions and the next release (in ~1-2 weeks) will be significantly more intuitive and easier to use.

Thanks for the feedback! :slight_smile:

1 Like

That worked great thanks!
Another quick question, I read this above:

Rani is about to start working on a “console” view of protocol analyzer results, which will basically allow the application to work as a serial terminal, which we’re really excited about.

Will this console allow for sending messages as well as receiving? (I guess like a console normally does , but just checking :slight_smile: )


That’s a good question actually, because we’re exploring various options at the moment. If it’s ok to ask, why would you like to send messages via the console?

1 Like