2.3.36 crashes Linux USB drivers after first SPI capture

I’m developing for an STM32 chip using an STLINK V3 from Pop!_OS 20.04 (Ubuntu derivative). I have been doing this for several weeks now, and I have not experienced an issue.

Today, I took out my Saleae to check an SPI transaction. It captured the transaction just fine. When I tried to capture a second SPI transaction, then it reported an error in a toast message. I closed the application and tried to reopen it, but it can no longer find the Saleae device. Interestingly, I can no longer upload code using my STLINK V3 either. This problem persists until I reboot my entire machine.

It appears the Saleae is attempting to send it’s capture data into the same buffer the STLINK is using for the debugging protocol, because it debugger starts spewing errors as soon as the capture stops.

Logic 2.3.36 errors:

  1. Occurs during capture…

    An error occurred during capture:
    :face_with_head_bandage: ReadTimeout

  2. Occurs while trying to start another capture…

    An error occured during capture:
    :slightly_frowning_face: DeviceSetupFailure

Sorry for the trouble with that… We’ve seen similar behavior in the past from other users of STLINK debuggers. Unfortunately, we haven’t found the root cause, but we suspect there is some sort of driver conflict as you might have suspected.

We noted a workaround below that some users have found success with (after rebooting your PC):

Would you mind giving that a try and letting me know if that helps?