Wall clock timestamps don't appear in graph

I am running Logic 2 v2.3.39 on Linux Ubuntu 20.04 using a Logic 8. I cannot see timestamps from the graph. I have 4 digital traces enabled (3, 4, 5, and 6). Here is what I have tried:

  • Scrolling the capture all the way to the beginning on the left
  • Checking “Use ISO8601 format” box in “Preferences” under the “Wall Clock Time” subheading.
  • After the above did not work, I also checked “Use UTC timezone” and unchecked “When Digital Trigger is enabled” and “When Analyzer Trigger is enabled” under “Auto Select Relative Time Mode”

I actually started on v2.3.37 where timestamps didn’t show up either but didn’t pay close attention to all my settings until I moved to v2.3.39

Note that I can see the time if I export CSV data which provided a passable workaround but it’s not ideal.

Am I doing something wrong or is this perhaps a bug?

@masonwardle This sounds like a bug. Can you share a screenshot of the issue? Also, can you share a copy of your .sal capture file?

@masonwardle You did mention that you tried scrolling all the way to the left. This certainly sounds strange. We highlighted the solution below, so I assume that you ran into that support article:

Looking forward to receiving your capture file to see if we can reproduce it.

Here is a capture with no activity:
no_activity.sal (16.1 KB)

I can provide my presets but your system doesn’t appear to allow me to upload them. If you want them, I could just add the .sal extension and upload but don’t want to break anything. Let me know.

Here are a couple screen captures:

First I scrolled all the way to the right:

Then I scrolled all the way to the left:

And here is the full export of the data (it’s short since no activity is on the lines):
Time [s],L->M,M->L,ENABLE,WAKE

I reread your responses and realized I missed something in what you were saying. I had not read that article. It may make for a better UX if the options are also added to the preferences which were easier for me to find. But I know how to do it now – thank you.

FWIW, I really like the Saleae and the app is getting better all the time too.

1 Like

@masonwardle Glad to hear the support article helped! Can I know what steps specifically solved it for you, and what confusions you initially ran into when trying to get the wall clock to appear? Hopefully this information will help us better understand what we need to improve to make this setting easier to work with, without having users resort to a support article.