Saleae

Unable to launch alpha on Linux

Hi folks,

I have tried to run the new alpha on Ubuntu 18.04 and ran to the following error:
k%C3%A9p

I have chromium-browser installed.
It might be useful to note what package/executable misses it exactly.

1 Like

Sorry for the trouble! After we discovered problems with QT’s QWebEngine, we hastily added code to just launch chrome as an interim solution until we finish integrating Electron (electronjs.io).

Specifically, on Linux, we:

  1. execute which google-chrome. If the response is empty, we display the above message.
  2. launch the process google-chrome with a series of arguments, including --app and --user-data-dir=, and a few others.

Since we’re switching to Electron, it’s unlikely that we’ll change this behavior before removing it entirely. In the meantime, I suspect that a quick symbolic link from google-chrome to chromium might get past this problem, but I haven’t tested it.

The front end won’t work with Firefox or other browsers though, which is why we dropped the original fallback that would use Qt’s solution to open the default browser if google-chrome was not found.

Let me know if that works, or if you run into trouble with it!

  • Mark, software lead & co-founder

Hi Mark,

Thank you for the answer. I have symlinked the chromium-browser as google-chrome and it works just fine.

Thanks and keep up your good job!

1 Like

Great to hear that fixed it Marton! Perhaps it will help others too.

My guess is that we will ship an alpha with Electron in <=2 weeks now. We have it essentially working internally. Then this issue goes away.