Since 2.3.12 Can't lower the frequency


W7 64 bits
very old logic 1.
with 2.3.13, I"m unable to change the frequency. I click on the combo box, it can see the list of frequencies. I click 8MHz, the combo closes but frequeny is still 24MHz.

I repaired the install with 2.3.12 installer, same behaviour
I de-installed 2.3.12 and installed 2.3.11. now it’s ok.


Hi Julien, could you re-test with 2.3.13? We fixed this bug specifically, and have tested it with the original Logic. You might have somehow ended up with just 2.3.12, which is the version with the problem.

Also, you can try resetting your application settings, by deleting the %APPDATA%/Logic/config.json file while the software is closed.

Hi Mark,

2.3.13 was “automatically” installed by 2.3.12.
I re-installed 2.3.13 “automatically” from 2.3.11 (I don’t see why this
can be different, but anyway…) it works now.


Hi Julien, thanks for confirming that worked! That’s certainly strange that you had to update from 2.3.11. Not sure how that happened exactly but we’ll keep an eye for similar reports of our auto-update system.

Hi Saleae

btw, V2 is far far better than V1, in terms of features and gui too.

good job.

1 Like