Problem with update to the latest version

Hi, I just got the message in the Logic 2 that a new version is vailable (2.3.9), and wanted to install it, but the installer fails. First it tries to find 2.3.7 installation file:


I cannot point it to the 2.3.7 installtion file, because it’s not there. I have 2.3.8 version installed already, but apparently there is an information somewhere that my current version is still 2.3.7. After cancelling I get this message:


I remember having some problems with update to the 2.3.8 version, and I think I have solved it by downloading and running the installer manually. Perhaps that mixed something up?

I tried downloading the 2.3.9 version and installing it manually - same problem.
I tried uninstalling my current version with “Programs and features” - same problem.

How do I update now?

Hi @kazink, sorry for the trouble!

This is a new one. Was a previous version of the software installed on a removable drive or a mapped network drive at some point? Also, did you manually uninstall any Microsoft Visual C++ Redistributables recently?

If all versions of the software are uninstalled, and we’re still seeing this problem on a fresh install, my guess is that there is something leftover in the registry.

Googling around, it seems like this problem has come up in the past with other applications. I’d suggest following the steps suggested here:

The same instructions appear to be repeated on a number of websites.

The product code set in all of our Logic 2 installers is “{5A89FE85-AC7E-4451-98C8-E6A78FE48EBD}”
Unfortunately, this is not the registry key name, which appears to be random. To quickly find the registry entry for our application, first navigate to the registry folder “HKEY_LOCAL_MACHINE\SOFTWARE\Classes\Installer\Products”. The search feature seems to start from whereever is selected, which will speed this up a lot.

Then use the regedit search feature with the following settings:

That should allow you to find our application installer’s entry:

I have both the 1.x and the 2.x software installed. You can tell them apart by looking that the Version entry, which contains the software version. (0x02030009 means 2.3.9)

The installer we use to package our application is called “Advanced Installer”. After quickly reviewing some results on their forum, and our installer configuration, I couldn’t find anything particularly useful. A few notes:

  1. We recently switched from bundling the Microsoft Visual C++ runtime 2017 to the 2019 version.
  2. The application updates don’t actually patch the existing install. When the software updates, it just downloads the regular installer and runs it in a non-interactive mode. The installer will automatically uninstall the existing installation before installing the installer’s copy.

Let me know if you don’t have any luck with the steps in that article.

1 Like

Hi and thanks for the thorough response.

No, the previous version was never on a removable or mapped drive.
No, I didn’t uninstall any redistributables.

I cannot check if the problem is still there after uninstalling all versions, because I cannot uninstall the current version for the same reason :slight_smile:

Thanks for the solution suggestion. I will be able to check it when I am back at work on monday.

I found the registry that indicated 2.3.7 version was intalled (0x2030007). I chabnged that to 2.3.8, and also changed the installer path in the SourceList sub-key. But then the installer started to fail at finding “Logic Setup 2.3.8.msi” file. After manual search it turned out this installer was missing too. I only had installers for versions 2.3.9, 2.3.10, and 2.2.11.

So I deleted the whole Logic key from the registry, and this time the update went fine.

1 Like

Glad to hear it, I hoped that would fix it. Please let us know if you see this issue again. So far this is the first we’ve heard of it.