Logic 2.3.37 failed to install on windows 11

Hello all,

My machine took the auto update from windows recently, and when I fired up the Logic it also took an update to install 2.3.37 and it failed to install the software. Tried to install several earlier version down to 2.3.30 and the problem still persisted and couldn’t use the device anymore. Does anyone here having the same problem? Any inputs will be greatly appreciated.

Best Regards,
TLN

Sorry about this… I’d like to gather some more information from you.

  1. Can you send me a message using the link below?
    https://contact.saleae.com/hc/en-us/requests/new

In the “Description” section, you can provide a link to this forum post so that I know it’s you.

  1. An an attachment to your message above, can you attach an installog.txt file? Instructions to get this file can be found below.
    The Software Will Not Install or Run Properly - Saleae Support

  2. In your message, please also include any information on what kind of errors you are seeing when attempting to install.

  3. Please also confirm your OS version.

Looking forward to getting this solved soon!

Hello Timreyes,

The OS I’m using is Windows 11 pro Insider Preview. Build 22463.rs_prerelease.210917-1503.
The error message were never displayed clearly, just the status bar rolling almost to the right then back to the left and this window.


Please advise. Thank you!

Best Regards,
TLN

@thelamnguyen Thanks for sharing that. It does in fact look similar to the error message in the support article I shared previously. My first hunch is that there is incompatibility with Windows 11. We haven’t run extensive tests on the new version on Windows yet.

I saw that you sent in your installog files via email. Thanks for that. We’ll be in touch via email.

Hello TimReyes,

I’m sorry for the late response. The software was working fine at rev 2.3.36 without any problems. However, once my machine took the windows update and in addition to that I accidentally update the Logic to version 2.3.37, the installation didn’t go through. I’m working with my IT department to revert the OS back to windows 10 then try again and keep you updated.

Best Regards,
TLN

@thelamnguyen Thanks for the update. We have some work on our end this week to verify our software with Win11. In the meantime, reverting back to Win10 might be a good idea. I’ll keep you updated on our test results.

We were able to run tests with Windows 11 on our end and succeeded in installing the software and necessary drivers. The Logic also connected and was able to capture data. It looks like Windows 11 is currently compatible with our products.

With that said, it’s possible that the installation error you are seeing might not be related to Windows 11, but instead could be related to another issue. In case your failed install attempt generated an install log file, could you send that over to us? Instructions are below:

This may contain sensitive information, so feel free to send that over via email using the link below. In the description section, just mention the link to this discuss forum and let us know that this message is for this post and we’ll know it’s from you.
https://contact.saleae.com/hc/en-us/requests/new

The same problems on windows 11 insider preview (latest update) - tried several versions, incl. the last one is 2.3.38. It is not installed (rollback is in progress, it was possible to disable rollback with the keys in the registry, because periodically it is necessary to analyze other people’s results), and the device driver does not work normally (refusal to install the driver, some errors on device manager page). On release windows 11 it works fine (on another computer).

Thanks for the extra information! It does seem like the problem could be specific to the insider program.

We’ve just installed Windows 11 on another machine and verified that the driver installation had no issues.

Now that Windows 11 has been released, are you planning on continuing to use the insider program?

I will roll back to windows 10. Insider has problems with Saleae (necessary for work), and in the release there are still problems with L3 cache (insider don’t have, but have problem with twitch too). I do not know yet. I’m waiting for the release patches, if the work with L3 is fixed in the near future, then I’ll go to the release.

Good to know! My main development machine has a Ryzen CPU, I’ll be sure to hold off updating too.