Problems updating from logic 1 to logic 2

I have been using logic 1 for a few years. Today I tried to upgrade to logic 2. I downloaded the Logic+Setup+2.3.46-master.exe and ran it. (note: logic 1 was still running and a saleae device was plugged in, whoops). The installation completed without errors, but when I try to run the program no application launches. 5 background processes open that are titled logic, one runs are about 27% cpu cycles/21.2 MB RAM and another at 11% CPU/33.2 MB ram. the other three are 0% and 5-6 MB ram. I am running windows 10 pro. I have tried uninstalling and reinstalling and rebooting my computer.

Any other ideas?

That’s very odd! Sorry for the trouble!

Could you send us a few things:

  1. run the software from the command line, and send us the output:
"\Program Files\Logic\Logic.exe"
  1. Send us your computer specs (make & model, or CPU & RAM), and make sure windows is up to date.
  2. Is this a company computer, maintained by an IT department, or a personal computer? if the former, there might be some sort of IT configuration interfering with our software.

The command line output from Logic.exe should look something like this:

  Executable path: C:\Program Files\Logic\Logic.exe
  Executable directory: C:\Program Files\Logic
  Original working directory: C:\Users\markg
  Current working directory: C:\Program Files\Logic
[2022-03-08 14:00:44.510095] [C] [tid   4100] [main] [saleae_log.cpp:219] Global logging level is set to: info
[2022-03-08 14:00:44.510101] [I] [tid   4100] [main] [saleae_log.cpp:221] Logfile path set to: C:\Users\markg\AppData\Roaming\Logic\logs\graphio-2022-03-08--14-00-43.log
[2022-03-08 14:00:44.836975] [I] [tid  40024] [main] [graph_server.cpp:735] DeleteGraphData SeesionId: -2
[2022-03-08 14:00:44.836980] [I] [tid  40024] [main] [graph_server.cpp:759] DeleteGraph( -2 ) called

If Logfile path set to: appears in the output, like it does here, please send us that file too.

Lastly, you could try running the software like this to get even more output:
"\Program Files\Logic\Logic.exe" --enable-logging

A few things to know about Logic 2:
Logic 2 uses electron for the UI, which is basically the chrome browser. Does your computer have any trouble running Chrome?

I will try what you asked. An update though. I tried going back through the older versions and up to version 2.3.40 it works. The change log states you changed to electron 15 in that version, I would guess that is my problem.

I use chrome as my main browser and it is up to date, no problems with chrome. This is an IT managed computer.

Here Is my cmd line output, it doesn’t get any further

Microsoft Windows [Version 10.0.19044.1526]
(c) Microsoft Corporation. All rights reserved.

C:\Users\mat.johnson>cd C:\Program Files\Logic

C:\Program Files\Logic>Logic.exe

C:\Program Files\Logic>
Executable path: C:\Program Files\Logic\Logic.exe
Executable directory: C:\Program Files\Logic
Original working directory: C:\Program Files\Logic
Current working directory: C:\Program Files\Logic

Hm… a few other customers have also reported that the app stopped working after the electron update.
We haven’t got to the bottom of the issue yet, but so far it seems like most users involved were on very old computers.

Could you send us your PC specs? If you right-click the start menu button and select “system” from the menu, you will get a quick summary.

Could you try running the software with:
Logic.exe --enable-logging
And send us the output, if it’s any different?
Oh - be sure to kill off any existing Logic.exe processes before trying again.

Yea my machine is pretty old. I am happy running 2.3.40 at this point. If I get a chance later this week I will try the modified launch command.

OS Name Microsoft Windows 10 Pro
Version 10.0.19044 Build 19044

|System Manufacturer|Dell Inc.|
|System Model|Vostro 270|
|System Type|x64-based PC|
|System SKU|To be filled by O.E.M.|
|Processor|Intel(R) Core™ i5-3450 CPU @ 3.10GHz, 3101 Mhz, 4 Core(s), 4 Logical Processor(s)|
|BIOS Version/Date|Dell Inc. A05, 2012-07-26|