Logic 2.4.13

2.4.13 Download Links


Welcome to the 2.4.13 release of Logic! This release contains a lot of changes under the hood, especially to how we save and load files.

Older files will load just fine, but files saved with 2.4.13 will not load into older versions of Logic.

If you run into any troubles with the release, please be sure to let us know.

Also, thanks to many of you for the feedback on the UI changes in the last release! We’re reviewing that now and I expect to incorporate some of the feedback in the next release.

What’s New

  • Added support for the latest Logic Pro 8 hardware revision. This new revision use a slightly different FPGA part number, due to supply chain issues from last year.

Bug Fixes

  • Finally, we’ve fixed the Linux 4GB memory limit. We are now using a custom build of Electron on that platform to solve the issue.
  • We fixed 2 issues introduced in the last few releases
    • We fixed the crash when changing the IO voltage level on the original Logic 16.
    • We fixed the crash on Linux when opening the software with a device already attached.
  • This is only about 10% of the changes in this release. The other 90% of the changes should not be visible now, but were made in support of future functionality.

Quick note: I installed this version yesterday.

One thing I ran into for the first time, was when I tried to install it, on my Windows 11 machine, it came up with dialog about needing to shutdown some app: McAfee … I should have written down the name.
I aborted the automatic update, and also then tried it by downloading from the website and ran into it again. I ended up telling it to continue as it failed to close that app, and then after going through that set of dialogs twice, it then installed and then said I needed to reboot to …

Again, this is the first time I ran into this.

Side Note: I appreciate that on the last few releases, that I can have two LA powered up and switch between tabs to use each one. :smiley:

@KurtE Thanks for the heads up on that. This is the first report of this kind of issue so far. I’ll keep an eye out for more reports of this in our support inbox before we take action to investigate.

For what it is worth, I had same issue with McAfee on the latest release

@KurtE Thanks for the heads up. We haven’t received other reports of this issue yet upon installation, but we’ll continue to keep our eyes peeled for it.

Did the installation end up finishing successfully? If so, what steps do you take exactly to get it successfully installed?

We’ve taken note of your description of the potential solution below, but it may help to know more information on that.

Also, what specific McAfee software do you have installed (name of software, year if relevant, etc)?

Yes was able to get it installed. Ended up killing off the McAfee task.


1 Like