Logic 2.1.5 (Alpha 17)

Unfortunately, I can’t reproduce this bug. Can you please provide us some more details?
Are you running Logic 2.1.5? Did you capture data before adding the analyzers? How did you add the digital channel (was it from the analyzer settings or from the capture settings menu?)

Thanks for the feedback! :slight_smile:

It can be both here and on the wish list :slight_smile:
First of all, we create a new feature requests board and you’re welcome to add ideas there as well:

We’re currently working on “High-Level Analyzers” that will allow you to add more layers on top of the raw data analyzers. In your case, you’ll be able to filter only DATA results, for example, and later on view them in the results table and export them.

In addition, we’re planning to upgrade the results table:

  • Support custom columns (based on the analyzer output)
  • Improved search (and filter) capabilities
  • Export the filtered results

Would those two be helpful in your case?

The detailed description is great btw. Thanks! :pray:

Hi Rani,

HW/SW context:

  • macOS Mojave 10.14.6 (18G2022) w/ MBPr 13" 2018
  • Logic2 Version 2.1.5 (2.1.5) w/ Logic Pro 8

I initially set up a digital only capture (ch 0,1,2) w/ SPI analyzer (0:MOSI,1:SCLK,2:/CS, no MISO), with /CS falling edge trigger and autostop after 1 second. I run a couple of captures and analysis w/ this configuration, zooming in/out, etc.

I then added the the Async Serial analyser. At this point I think I hadn’t enabled the 4th channel (ch 3: UART), so I guess it (or I) picked up one of the CH0/1/2 as UART source. I then went back to the channel settings to enable ch3 as digital, then went back to configuring the Async Serial analyzer which failed to show CH3 as an input channel.

See attached snapshot if it can help.

1 Like

Another glitch: for some reason, all the analyzers (SPI, UART) have disappeared and I cannot start any capture anymore, whereas Logic2 still reports the Logic Pro 8 is indeed connected (and its led is shining). Did I miss something? I have a screencast if it can help to demonstrate this issue, but it seems Discuss won’t let me attach it (it is only 212 KB).

This occurred twice since yesterday: once while enabling with the “terminal” button, then when I locked the computer (it may have entered low power mode, I’m not sure).


I must say I really like this version. The interface is nice, and I think it’s much faster than previously.

I’ve noticed a slightly odd issue with the SPI analyser: I have a capture file with an SPI capture, with the following signal to channel assignment:
channel 0 => active low CS
channel 1 => clock - data asserted on a falling edge, data sampled on a rising edge (CPOL=0, CPHA=0). 8 bits per transfer
channel 2 => MOSI
channel 3 => MISO

The analyser is showing the SPI bytes (on MOSI and MISO) correctly, for most of the capture, but towards the end (1s : 6ms: 929µs), it stops showing the bytes.

I have tried to upload the capture file, but the forum does not allow the *.sal extension to be uploaded (something to consider allowing, maybe?), so I’ve included a screenshot, instead!

Many thanks,

Andrew Walsh.


1 Like

Ok, I can even reproduce it with another Async Serial analyser:

  1. Add channel 4 as a digital channel
  2. Add a new Async Serial analyser: ch 4 is not selectable
  3. Capture/Stop immediately
  4. Add a new Async Serial analyser: ch 4 is now selectable and automatically selected.

Another issue:

  1. Falling edge trigger is selected (on /CS == ch 3)
  2. Click on “reset” to remove capture trigger
    • rising edge is selected - I would have expected no selection here, as no trigger
    • trigger channel is cleared out
  3. Capture/Start button becomes greyed, it is not possible to start a capture. It seems it is due to the “rising edge” associated with no channel. If any trigger is selected, the Capture/Start button is enabled back. How to actually remove a capture trigger then?

Screencast available if required.

We’ll look into all of these issues. Sorry about that :pray:

What do you mean by disappeared? from the session?
Is there a chance that a new session was created due to device disconnection?

This is great, I’m happy to hear that :slight_smile:

We’re less happy about the bug…
You can now upload the sal file (thanks for the idea!)

Ohhh, now I get it :slight_smile:
It’s mainly a visual bug, as the channel is still “disabled” for the analyzer if you already have captured data. However, we definitely to fix that.
Our solution will be to allow you to select that channel for the analyzer, but it’ll be disabled until you’ll capture new data that includes the new channel.

Thanks a lot for the detailed explanation!

In regards to the trigger issue, you can remove the trigger by selecting another capture mode (Timer or Looping). We’ll also fix the reset button to restore the values to the default settings instead of the invalid state.


Thanks for your fast reply. I’m afraid that I still can’t upload the sal file (i.e. when I use the upload button when editing this reply, select the file and click “Upload”, it still tells me it’s not an allowed file type).
However, I’m no longer sure it’ll tell you anything useful: weirdly, when I reopen it, the SPI analysis is shown for all frames, so you can’t see the problem (when I saved it yesterday, I placed a book mark at the place where the problem started, which is still there).
If you still want to look at the file, though…

Ok, thanks.

BTW, It would be nice to have a bug tracker at some point, forums are not that great (IMHO) to track issues, against which versions they have been reported, when they have been fixed, and to avoid tracking several issues within the same thread of discussions :slight_smile:

Suggestion: it would be nice to get a quick way to count decoded sequences:

  • a marker pair to count event between two selected points
  • an absolute counter for the whole sequence
    I.e. to be able to count the number of SPI clock cycles, the number of SPI or UART bytes, etc.

Sorry, wrong permissions. It should work now.
We’ll try to reproduce that here, but if you find a way to reproduce it yourself please let us know :pray:

I agree, we’re planning to share our bug tracker and roadmap

1 Like

That’s a cool idea! I’m hoping that it’d be possible via the High-Level Analyzers.
I added it to the feature requests:

In case it’s useful, I’ve attached the capture file.200121-2_SPIRIT1_SPI.sal (754.7 KB)

1 Like