Logic 2.1.5 (Alpha 17)

I’m sorry that it crashes frequently. I believe that your experience with Logic2 will be much better over time! :slight_smile:

We can add the double click to zoom. That would be easy.
In regards to the markers, a new version will be released next week. I’d love to get your feedback and hear if those features are still missing.

Add horizontal(voltage) cursor support for analog trace

I’m not sure that I understand your request. Can you please elaborate?

Thanks a lot for the feedback, it’s super helpful!

I found interesting bug in 2.1.5 related to changing height of channels view:

  1. Setup Logic software to capture at least 2 analog channels
  2. After capture complete, change height of any channel
  3. Click on “Set all channels height to current”
  4. See that other channels range is increased out of Saleae Logic measurement range, but -10…+10 range still in old scale.

Hope it will be helpful.

1 Like

It’s helpful :slight_smile:
We’ll fix it, thanks!

Hi Rani

Great to hear you back, and I am certainly happy to try out the new release in the future.

For the cursor I mentioned, it can also be called as Marker, Cursor is a more popular word in the Oscillator scope.

The ask is basically to have something telling the user what are the analog voltage values from a to b.

Here are the 2 possible UI I am visioning(Plan 2 is personally preferred, but may ask for more work)

Plan 1: Add analog voltage value to the marker/s

Plan 2: Add horizontal(voltage) markers, and list out the values at the markers’ bucket.

1 Like

I2C Analyzer Colors

I have two I2C analyzers enabled. Changing the colors of the text between them is great. However, for the second analyzer, the text is white on an orange background. At least for me, this is hard to read. I’d prefer black text on the lighter backgrounds - like orange. Or, allow me to pick the colors. Maybe it is just that my eyes are getting older and I have issues seeing the contract between two light colors.

1 Like

There is a glitch (I’m not sure in which version it has been introduced) with the analysers. Sorry if it has already been reported, as I haven’t had the opportunity to use the alpha series for a while:

  1. SPI analyzer configured for digital channels 0/1/2 (sclk, mosi, /cs)
  2. Add a new digital channel (3)
  3. Add a new async serial/uart analyzer. Only channels 0 to 2 are selectable, channel 3 does not appear in the list

workaround: run a dummy capture session, get back to the analyzer settings, channel 3 is now available; i.e. it looks like it is not possible to analyze a channel for which no capture has yet been performed.

Update: I clicked on the “Terminal” button, and deselected it, and now the “Start” button seems to stay disabled for ever. Weird.

Sorry, I am not sure if this should go here on in wish list stuff.

I know I mentioned earlier about USB capture stuff, (USB LS/FS analyzer) and mentioned, that I wish I had more control over what things that showed up in the decoded protocol and later output reports.

I use this analyzer when working with Teensy 3.6/4.0 USB host code support. Often when I wish to help support a different USB Mouse or Keyboard, Joystick, Serial Adapter,… Often times I try to analyze the communications that happen when you plug that device into some host that supports it, and then compare it what my code is doing and iterate until I get something working.

Often times, I will start up a capture and then plug the device in and let it run for maybe 15 seconds, with Logic 1 I would then export all of the data to a csv file and then try to extract the relevant data. The initial output file could be at times something like 50000 lines long sometimes millions of lines. Often times I could reduce this down to a few hundred lines that I might actually want to look at.

Some details about what I would do, is up in the thread: https://forum.pjrc.com/threads/55457-How-to-do-multiple-REGEX-search-and-replace-operations-in-large-file.

When I do this, I am mostly interested in those lines that have DATA associated with it, plus a line or two before and after. I tried a lot of the reduction using sublimetext editing, but found that part was slow, so I would take the file to a unix board and use grep.
In the above mentioned thread, I had a capture that output > 3 million lines.

The linux command

grep -B1 ",DATA" USB_Capture_WIndows_XBoxOne_Pair_packets2.txt > u2

Reduced this down to 2066 lines. then in sublime text I used a regular expression search and replace:

Search: ".*\b(IN|OUT|SETUP),0x[0-9]*,(.*)\n.*DATA[0-1],,,(.*\n)"
Replace:  "$1,$2,$3"

Also also another one that replaced multiple ,'s with a , (may have to run it a few times)
Which in this case brought the file down to 689 lines.

When I then bring the file into excel it was a lot easier to look at, starting like:

SETUP	0x00	0x05		0x00 0x01 0x01 0x00 0x00 0x00 0x00 0x00
IN	0x00	0x05	0x0000	
SETUP	0x00	0x05		0x20 0x00 0x00 0x00 0x00 0x00 0x04 0x00
OUT	0x00	0x05		0x59 0x0C 0x01 0x00
IN	0x00	0x05	0x0000	
IN	0x01	0x13		0x0E 0x04 0x01 0x59 0x0C 0x00
SETUP	0x00	0x05		0x20 0x00 0x00 0x00 0x00 0x00 0x08 0x00
OUT	0x00	0x05		0x01 0x04 0x05 0x33 0x8B 0x9E 0x05 0x00
IN	0x00	0x05	0x0000	
IN	0x01	0x13		0x0F 0x04 0x00 0x01 0x01 0x04
SETUP	0x00	0x05		0x20 0x00 0x00 0x00 0x00 0x00 0x0A 0x00
OUT	0x00	0x05		0x0B 0x20 0x07 0x01 0x12 0x00 0x12 0x00 0x00 0x00
IN	0x00	0x05	0x0000	
IN	0x01	0x13		0x0E 0x04 0x01 0x0B 0x20 0x00
SETUP	0x00	0x05		0x20 0x00 0x00 0x00 0x00 0x00 0x05 0x00
OUT	0x00	0x05		0x0C 0x20 0x02 0x01 0x00

Again I know that this is probably a wish list like thing, but thought I would mention it here, to see may if this analyzer has any plans to be enhanced, with maybe the idea of the ability to better chose the data you wish to see both in the reports as well as in the decoded protocol window.

Thanks

Thanks a lot for the detailed explanation!

Are you interested in the voltage at the time of the marker or in the average/max/min voltages between the markers?
The reason I’m asking is that we’re currently working on the advanced measurement tool that will allow you to generate different metrics for a selected region. You’d be able to get the average/max/min voltages or write your own metric in Python.

By the way, you’re welcome to add option 2 to our new feature requests page if you’d like:
https://ideas2.saleae.com/b/feature-requests/

I’ll ask our designer to find a more readable color.

In addition, I added your idea to our new feature requests page, you’re welcome to vote for it :slight_smile:
https://ideas2.saleae.com/b/feature-requests/allow-users-to-select-analyzers-color

Unfortunately, I can’t reproduce this bug. Can you please provide us some more details?
Are you running Logic 2.1.5? Did you capture data before adding the analyzers? How did you add the digital channel (was it from the analyzer settings or from the capture settings menu?)

Thanks for the feedback! :slight_smile:

It can be both here and on the wish list :slight_smile:
First of all, we create a new feature requests board and you’re welcome to add ideas there as well:
https://ideas2.saleae.com/b/feature-requests/

We’re currently working on “High-Level Analyzers” that will allow you to add more layers on top of the raw data analyzers. In your case, you’ll be able to filter only DATA results, for example, and later on view them in the results table and export them.

In addition, we’re planning to upgrade the results table:

  • Support custom columns (based on the analyzer output)
  • Improved search (and filter) capabilities
  • Export the filtered results

Would those two be helpful in your case?

The detailed description is great btw. Thanks! :pray:

Hi Rani,

HW/SW context:

  • macOS Mojave 10.14.6 (18G2022) w/ MBPr 13" 2018
  • Logic2 Version 2.1.5 (2.1.5) w/ Logic Pro 8

I initially set up a digital only capture (ch 0,1,2) w/ SPI analyzer (0:MOSI,1:SCLK,2:/CS, no MISO), with /CS falling edge trigger and autostop after 1 second. I run a couple of captures and analysis w/ this configuration, zooming in/out, etc.

I then added the the Async Serial analyser. At this point I think I hadn’t enabled the 4th channel (ch 3: UART), so I guess it (or I) picked up one of the CH0/1/2 as UART source. I then went back to the channel settings to enable ch3 as digital, then went back to configuring the Async Serial analyzer which failed to show CH3 as an input channel.

See attached snapshot if it can help.

1 Like

Another glitch: for some reason, all the analyzers (SPI, UART) have disappeared and I cannot start any capture anymore, whereas Logic2 still reports the Logic Pro 8 is indeed connected (and its led is shining). Did I miss something? I have a screencast if it can help to demonstrate this issue, but it seems Discuss won’t let me attach it (it is only 212 KB).

This occurred twice since yesterday: once while enabling with the “terminal” button, then when I locked the computer (it may have entered low power mode, I’m not sure).

Hello,

I must say I really like this version. The interface is nice, and I think it’s much faster than previously.

I’ve noticed a slightly odd issue with the SPI analyser: I have a capture file with an SPI capture, with the following signal to channel assignment:
channel 0 => active low CS
channel 1 => clock - data asserted on a falling edge, data sampled on a rising edge (CPOL=0, CPHA=0). 8 bits per transfer
channel 2 => MOSI
channel 3 => MISO

The analyser is showing the SPI bytes (on MOSI and MISO) correctly, for most of the capture, but towards the end (1s : 6ms: 929µs), it stops showing the bytes.

I have tried to upload the capture file, but the forum does not allow the *.sal extension to be uploaded (something to consider allowing, maybe?), so I’ve included a screenshot, instead!

Many thanks,

Andrew Walsh.

200121-1_Saleae_Screenshot|690x431

1 Like

Ok, I can even reproduce it with another Async Serial analyser:

  1. Add channel 4 as a digital channel
  2. Add a new Async Serial analyser: ch 4 is not selectable
  3. Capture/Stop immediately
  4. Add a new Async Serial analyser: ch 4 is now selectable and automatically selected.

Another issue:

  1. Falling edge trigger is selected (on /CS == ch 3)
  2. Click on “reset” to remove capture trigger
    • rising edge is selected - I would have expected no selection here, as no trigger
    • trigger channel is cleared out
  3. Capture/Start button becomes greyed, it is not possible to start a capture. It seems it is due to the “rising edge” associated with no channel. If any trigger is selected, the Capture/Start button is enabled back. How to actually remove a capture trigger then?

Screencast available if required.

We’ll look into all of these issues. Sorry about that :pray:

What do you mean by disappeared? from the session?
Is there a chance that a new session was created due to device disconnection?

This is great, I’m happy to hear that :slight_smile:

We’re less happy about the bug…
You can now upload the sal file (thanks for the idea!)

Ohhh, now I get it :slight_smile:
It’s mainly a visual bug, as the channel is still “disabled” for the analyzer if you already have captured data. However, we definitely to fix that.
Our solution will be to allow you to select that channel for the analyzer, but it’ll be disabled until you’ll capture new data that includes the new channel.

Thanks a lot for the detailed explanation!

In regards to the trigger issue, you can remove the trigger by selecting another capture mode (Timer or Looping). We’ll also fix the reset button to restore the values to the default settings instead of the invalid state.

Thanks!

Thanks for your fast reply. I’m afraid that I still can’t upload the sal file (i.e. when I use the upload button when editing this reply, select the file and click “Upload”, it still tells me it’s not an allowed file type).
However, I’m no longer sure it’ll tell you anything useful: weirdly, when I reopen it, the SPI analysis is shown for all frames, so you can’t see the problem (when I saved it yesterday, I placed a book mark at the place where the problem started, which is still there).
If you still want to look at the file, though…