Failed to load custom analyzer (

Image of popup message during Logic 2.0 (2.3.19) startup:


I did find a similar thread from a month ago which I believe relates to a Custom Analyzer being written. The problem I’m having is from a custom analyzer I don’t even recall installing. It’s been several months since I’ve needed to use the device and so the message stumps me. :thinking:

Mac OS (10.12), Logic Pro 8. Message appears no matter what version of the app I start, tried several version 2.3.x. Tried removing the apps/system directories that relate to Logic, reinstalled and still get message.

Is there something I need to uninstall do remove this message? Sorry for the Newb question, but been quite a while since I used the tool… so apparently I’m now the tool. :smiley:

Oh no! This is strange behavior. We actually had someone report this fairly recently.

As a workaround for now (and as long as you don’t plan on using the midi analyzer), can you navigate to that folder location and cut/paste the file to your Desktop? Let me know if that removes the popup for now. I’ll need to review this bug with the team here.

Copied the file from the to the desktop… and trashed the app copy.

No analyzer to cause the message, so I’m happy (not likely to use midi analyzer in the near future anyway). Any reason I should hold onto the desktop copy. If there is a later solution I suspect it will be a later release, and even if not - I can simply reinstall a new copy.

Appreciate you pointing out an obvious solution that I simply didn’t even consider. :+1: :+1:

@ChrisMcK Glad to hear that worked! No reason to hold on to a copy of that file. We’ll need to get that fixed in a later update to the software, so no need to worry about that. I’ve got this on our backlog to review now.

@ChrisMcK mind if I ask why you’re still on MacOS 10.12? That may be the issue. I think our build system targets 10.13 at the moment, and we were thinking of moving that up to 10.14 based on usage.

Just the system doesn’t support upgrading to High Sierra (system isn’t supported). If support for 10.12 has been dropped I’ll start using it on my perpetual upgrade machine (PUM aka Windows 10). Or I’ve been kicking around the idea of getting a Linux box running under my bench.

@ChrisMcK Thanks for letting us know, and glad you have an alternate solution for now. I went ahead and created a support article, since it seems that a handful of users have run into this issue (enough to warrant writing this up and hopefully having other users find it in case they run into the same issue).