Black screen after loading on Ubuntu 20.04

Hello folks,

The latest 2.2.15 update solved the libffi dependecy problem, however I still cannot use the Logic2 because it stuck on loading with a black screen:

The menus are there however they all disabled (except the edit):

I have tried to erase the .config/Logic folder but it did not helped.

Here is my command line output:

I have an NVIDIA NVS video card, but apart from that nothing special. Other similar software (like Chromium, or Teams runs just fine.)

Any help would be appericiated!

Have you tried deleting that folder while the app is closed?

1 Like

Another option is that the app failed to get a WebGL context (for rendering analog data). We’re currently not handling this error properly, as we assumed that all platforms support that :slightly_frowning_face:

1 Like

Of course I deleted when the app was not running :smiley:

Is there any way to determine if the WebGL context fails?
I can extract the appimage and can alter files if necessary.

I have tried this WebGL test:
with both Chrome and Firefox and both browser reports that both v1 and v3 is supported.


Is there any way to determine if the WebGL context fails?

Unfortunately no. We’ll make sure to show an error message on the next version.
I’m sorry for the trouble.

1 Like

I assume you’re still running with the nVidia drivers loaded? Have you tried starting the “NVidia X Server Settings” app and switching to power save / Intel graphics mode? I went to test this myself. I almost always run in power saving mode in Linux and dual boot to Windows to play games with the nvidia card. So, I went to switch to nvidia in Ubuntu 20.04 to test. But, for some reason after the 20.04 upgrade linux no longer sees my nvidia card at all. The nvidia driver says no cards found and lspci and lshw show no nvidia card at all. Don’t know what changed but I can’t enable the nvidia card in linux to test for you.

If you use sudo Logic --no-sandbox it works on Ubuntu 20.04. I’m not sure why it doesn’t work without it, but it may be you need some permissions to something or other.

1 Like

Just using Logic --no-sandbox works as well.

Fixed in the 2.2.16 (works without the --no-sandbox option too)

Thank you folks!

1 Like