Logic2 cant detect saleae

Long time Saleae user and happy with 1.2.xx. Today a second try to jump on the new Logic2.
and a second time i cant get it to work on my Ubuntu 20 machine.

  1. why can’t i run it as ‘root’ or ‘sudo’.
    I really don;t understand why you force users to run it in user mode.
    Those who know, understand the risk. and I too agree ‘user’ mode is better.

But what is the point I need to have ‘root’ access anyway to setup user mode.
FYI, setting up user mode is not an easy thing todo. on on various system you face various possible reason to fail.

Now I cant run and install Logic2 quickly on a test machine, without jumping through ‘too many’ hoops.

Launching Logic 2 the first time instructs me to setup the udev logic. Quickly done following the instruction. Re-start for the second run, but it can find any Saleae device.
(Its connected and working though, trust me, i used it with Logic 1.2.)

  1. tried the --no-sandbox, but no dice here either. It crashes for some GPU process exit code 1024.

  2. no i am really sad.

  3. I have faith in you guys, long time admirer on your product.
    Please make Logic2 usable. I know it is tough to supports so many diff platform.

And please enable ‘sudo’ again , there are many of us who use it for years in such way

@mattes Sorry for all the trouble with getting the Logic 2 app running… the GPU process issue you are describing sounds like a WebGL error.

Besides attempting to try Logic 1.x, since you got that working, can you let me know the results of the other solutions listed below?

Also, I’m curious to know what GPU is installed on your PC. We’ve received reports of a handful of GPU models that seem to be causing WebGL issues, which we’re keeping track of below: