Serial and Dynamixel analyzer incorrect hex values

I’m trying to read commands from a dynamixel using async serial and the dynamixel v2 analyzers.

I’m scoping both of the differential outputs and D1 is D- and D2 is D+. When I ping the dynamixel, I get this:

The hex values for the ping should be
and the values for the return status packet should be

The settings for D1 and D2 are:

For more context, I’m sending a ping to dynamixel ID 2 (which is the one I am scoping) from the dynamixel wizard and there are two dynamixels on the same bus.

I’m on windows 11.

Any thoughts on this would be appreciated!

Which servos are you using? I am assuming they are one of the RS485 versions. I have never had any of these so may be limited in helping. I have mostly played with AX servos and later XL430…
Which ones are you using?

But some of the things I would look at include:

a) What is your sample speed for the analyzer setup, hopefully a multiple of the 2MBs baud rate? Might help to see a more zoomed in view, showing where each bit is sampled.

b) Which analyzer. With my Pro at times I need to make sure that I have an appropriate voltage selected.

c) Are the servos and whatever they are talking to configured for 2M. I believe the
XL430 default to 57600 and the AX to 1Mbs…

As for the Dynamixel Analyzer, guessing won’t work until the Serial data is correct.

For what it is worth, I used to play around with my own Low level analyzer:
KurtE/SaleaeDynamixelAnalyzer: Dynamixel Analyzer for Saleae Logic Analyzers (

But later built my own HLA:
KurtE/SaleaeDynamixelAnalyzer_HLA: Saleae High Level Analyzer for Robotis Dynamixel Servos (

But have not done anything with them for a couple years now.

Hi, thanks for the reply.

I’m using the XM430-W210 servos and yes they use RS-485.

b) The analyzer is Logic 8 pro. I tried 1.2 and 1.8V for the voltage.

c) The servos and the board they’re talking to are configured to 2M.

d) Yea, I just had the dynamixel analyzer there but I’m ignoring that until I can get Serial to work properly.

a) Thanks for catching the sampling rate - I changed it to 100MS/s. That seems to make things a little better, but still not consistent. Below are screenshots after I changed the sampling rate.

Here is the ping itself:

And here is the corresponding status response:

I copied the hex values that I should be seeing below:

Cool, I’ll take a look!

Here’s more of a close up:

Sorry, not sure much more I can say…

I would configure for 3.3v+ as at least their RS232 signals are 5v, guessing probably the same.
But again guessing.

It looks like either lots of signals going on, or noisy, which I often get when it is configured for the wrong voltage.

If it still looks like that at 3.3v you might try turning on the glitch filter on one or both of these channels, for maybe 1us and see if that helps