Java Script Error: Read-Only File System

Hi all,

whenever I try to save a capture I am getting the following error:

I am running a freshly installed Ubuntu 22.04.
I tried to execute the AppImage, the extracted binary as well as the AppImage with --no-sandbox.
Error persists.

Does anybody have a suggestion on how to fix that issue?

Help greatly appreciated.

Best regards,

@sass Strange! What folder location are you saving to? Is it possible that folder location is configured as “read-only” as suggested by the error message? Have you tried saving captures to other folder locations that allow for write access, and do you still get the same error message?

Yeah, it is really weird! :slight_smile:

Just using your .AppImage from different locations. Of course with chmod +x before.
I tried file stores to different locations, some relative to the current directory and some absolute but definitely write permissions in any case.

In case somebody comes here due to observing the same behavior, I was extracting the .AppImage using
and then
chown -R $USER:users
on the extracted folder.
When I then execute the binary directly, it is functional.

Not quite sure what is going on here, but it works for now. :slight_smile:

Best regards,

@sass Oh wow… thanks so much for sharing your workaround, and I’m glad you got to the bottom of that. I’m a bit stumped at the moment as to why that would fix it.

I’ll send share this behavior you described with our software team.

Hi @sass,

That’s very odd. Could you tell me what the user & group was for those files before the chown -R operation?

ls -l should show you for the top level at least. ls -l -R technically loads all of it, but the output is pretty painful to sift through. Could you also check the groups your user is a member of with the groups command, to see if (A) the owner of the extract files is the current user and (B) the group of the extracted files is a group that your user account is a member of?

I just ran a quick test over here, and after running --appimage-extract, all the extracted files already had the correct user and group.

Also I noticed you were setting the group on the file to ‘users’, which as far as I can tell, isn’t one of the default groups on Ubuntu. Is there any chance you deleted the default group which shares the same name as your user account, and created a new group called ‘users’, which you then added your account to?