Saleae Logic 2 appimages do not work


I use Linux Kubuntu 18.04 LTS and 22.04 LTS. I have tried several versions of Saleae Logic 2 appimage. No one (except of 2.3.15-master) works, either in 18.04, or in 22.04.

Here is listing from console:

user@user-A22-D8A:~/Plocha$ ./Logic-2.4.2-master.AppImage
/tmp/.mount_Logic-IWFg0c ~/Plocha
A JavaScript error occurred in the main process
Uncaught Exception:
Error: /tmp/.org.chromium.Chromium.Gm9u7Q: failed to map segment from shared object
at process.func [as dlopen] (node:electron/js2c/asar_bundle:5:1812)
at Module._extensions…node (node:internal/modules/cjs/loader:1203:18)
at Object.func [as .node] (node:electron/js2c/asar_bundle:5:2039)
at Module.load (node:internal/modules/cjs/loader:988:32)
at Module._load (node:internal/modules/cjs/loader:829:12)
at c._load (node:electron/js2c/asar_bundle:5:13343)
at Module.require (node:internal/modules/cjs/loader:1012:19)
at require (node:internal/modules/cjs/helpers:102:18)
at bindings (/tmp/.mount_Logic-IWFg0c/resources/app.asar/node_modules/bindings/bindings.js:112:48)
at Object. (/tmp/.mount_Logic-IWFg0c/resources/app.asar/node_modules/ref-napi/lib/ref.js:7:47)

(Logic:6261): Gtk-WARNING **: 13:58:51.476: Could not load a pixbuf from icon theme.
This may indicate that pixbuf loaders or the mime database could not be found.

Does anybody have similar problem?

Saleae Logic 1.x (all versions) works without any problem.

Thank you.

That’s weird because I’m using Kubuntu 22.04 and they’ve been working fine for me. Here’s an example of it running for me:

/tmp/.mount_Logic-gmZZQY ~/Desktop
Executable path: /tmp/.mount_Logic-gmZZQY/Logic
Executable directory: /tmp/.mount_Logic-gmZZQY
Original working directory: /home/collin/Desktop
Current working directory: /tmp/.mount_Logic-gmZZQY
Process ID: 19011

Unfortunately, I guess I can’t be of much more help than that. I’ve been using them right along so I don’t see any reason it shouldn’t work. Your error doesn’t make a lot of sense to me.

I once had a problem with appimages that turned out to be caused by a truncated appimage. The error messages were confusing/misleading, but different, so I don’t think it’s your problem—but just in case try re-downloading the appimage.
Your error messages are too high level for me to understand what is going on; try running the appimage under strace----maybe it’ll show what causes this map failure. You can’t run the appimage directly under strace, but you can extract it and run the extracted binary:

Logic --appimage-extract
cd squashfs-root/
strace -f ./AppRun

and try to correlate the maelstrom of syscalls with the exception you’re seeing. You can try

strace -f ./AppRun 2>&1 | less

searching for ‘JavaScript error’ or maybe Esc > to go to the end, and go back page by page

@zaloha Apologies for the issues with that! I’m not sure what could be causing this. Since you are able to get 2.3.15 working, my hunch is that an Electron update may have broken it for you.

Can I know what versions of the software you have tried? Namely, I’d like to see if you can get the following running to help pinpoint where the issue might be coming from:

  • v2.3.56: Saleae - Changelog
    (this was the last version before we made the udpate to Electron 19)
  • v2.3.40: Saleae - Changelog
    (this was the last version before we made the update to Electron 15)

Also, can I know what exactly happens when you attempted to launch 2.4.2? Does the software UI appear at all?