Debian Buster support

Hi group,

I used the 32-bit version of Logic1 at 32bit Debian Jessie system pretty comfortable without any problem for some years. For now, I turned to 64bit Buster and have problems with a SW install.

For a first try, I downloaded Log2 as AppImage. But I use plain debian and won’t enable user userspace namespaces. Thus, blind road and installer suggests “use DEB package”. I cannot find any oldstyle DEB package of Log2.

Well, OK, let’s try old Log1, version 1.2.29. It starts, but says it’s outphased and quits. No chance to run.

I tried to extract squashfs from appimage and run it from this. Again, no success, crash after starting of Logic binary.

Is there either a correct 64bit DEB package of Log2, or not outphased DEB of 1.2.29 (or similar)?

I like the analyzer’s hardware, it’s pretty sufficient for me, I was fully satisfied with the Log1 functionality, but now I cannot use the analyzer at all.

Thanks for any idea,

Karel, Prague, CZ

@kj1 Sorry about that “outphased” error in Logic 1.2.29! First, let’s get Logic 1 working since we have a quick solution for it. There are 2 options below:

  1. Bypass the warning message using the solution described below:

  2. You can use 1.2.40 below. We removed the error popup in that version. However, 1.2.40 is provided as an AppImage file only, so you might run into the same issue attempting to extract squashfs and running the binary from there.

As for the issue below:

Did you try this for both Logic 1 and Logic 2 AppImages? For 1.2.40, and Logic 2, we only provide the Linux Ubuntu release as an AppImage. We don’t provide a DEB package. However, you should just be able to extract squashfs and run the binary from there.

Hopefully number 1 above gets you up and running quickly. We don’t officialy test and validate our software on Debian (we officially support Ubuntu). However, I’m going to check with the software team here to see if there may be an obvious solution to this issue.

Hi Tim,

thanks for a quick reply. I helped myself already, but in a sligthtly “dirty” way - I found somewhere the install of the 1.2.18 version, which does not generate the “outphased” splash. This way, I can use my little dongle (24MSa/s 8ch USB thing) again. Happy, but … not the best solution.

Next, thanks tor the --override option, I’ll try later. Good idea from the SW developer! My only need to try the Log2 branch was … my curiousness. I’ll try to play with the extracted squashfs more (I tested appimage of Log2 only so far), but I always get very strange debug yell, without success. Pitty, you don’t provide the .deb package model.

But, as we know, patience brings roses. Thank you for all the fish.

Wish you a nice rest of summer and plenty of health!


Hi again,

appears like SOLVED! The main trick sticks in the UDEV subsystem. While unpacked the squashfs inage, I found under .resources some 99-Saleae… UDEV rules file. Just moved it into the proper location under /etc/udev, then

  • restarted UDEV (systemctl)
  • replugged device
  • ran appimage as an ordinary user … and … voilá, I am “up to date” with the Logic 2 software ( master, 2.3.56, Commit: 6d658bece22e848dd0890e82e8903485798f3195 ) at an oldschool pure Debian (not a windowsish Ubuntu).

The SW looks very interesting, going to investigate It.

Thanks for a help!


1 Like