Logic 2.3.38

Download Links

Windows - Linux - MacOS

What’s New

Note: The following only affects devices with Apple M1 silicon

We’ve implemented updates to the Logic 2 software that hopefully improves stability on Apple’s M1 processor.

Please note that this release is experimental and may contain bugs or stability issues. Please report any issues you experience with this version via the methods below.

When I tried launching the app today, it didn’t open, even after a restart. No response whatsoever when launching from desktop - on the command line it just hanged. I downloaded it from here and selected “repair” in the installer, then it worked again. Not sure if it’s related to this release, just an observation

Thanks for the information, and sorry for the trouble! Please let us know if it happens again.

I’m not sure what could have caused that. The application preferences (the only thing I suspected could be related) aren’t cleaned up on uninstall or repair, so the installation must have somehow been damaged.