Logic 2.3.19 Does USB LS and FS work at all?

I thought I would try a quick capture to see how hard it might be to modify the USB LS and FS analyzer to maybe have a new decode level - like Packet with Data…

But first thought I would try a capture with current release and I am a bit rusty so don’t remember which is the D+ versus D- but I tried both ways…

So far the analyzer that is part of the build is not analyzing anything. It sits at 0% and if I try different settings it always just shows RESET only at start like:

So wondering if it is working at all with current build?
Here is a partial capture.
USB_Mouse_startup.sal (26.6 KB)

Now back to playing. Note: What I wanted to really capture was the startup of a thumb drive, but as expected it is running at the 480mhz and nothing shows up in the analyzer.

@KurtE The usb analyzer in your capture might have had the incorrect speed setting. Setting to 1.5Mbps solved it for me. Can you double check that?

Here is the updated capture file:
updated-USB_Mouse_startup.sal (24.1 KB)

Kurt, one thing we’ve done in the past is to plug a USB 2.0 high speed device into a USB 1.1 hub. They can be hard to find though. I think we picked one up off of Amazon 5-8 years ago.

Thanks, it is working.

I actually started off yesterday with low speed, but for some reason it would not detect it properly…
Not sure why… I tried all 4 combinations of Speed and which pin is + and -

Maybe it was just having an off day.

Also good idea of trying to go through a slow hub. Which is an interesting point of wondering what the HUB is I am testing on the T4.1 with USB thumb drives…

Thanks again

1 Like